USB/printer problems

  khareji 11:56 03 Dec 2005

I recently installed a USB 4 port mini hub, which my computer recognised and installed with no probs. However, after a few days I went to print out a letter and got a message that there were problems with the printer. I also noticed that on the taskbar the icon for my printer had an "X" next to it. I decided to uninstall the printer then reinstall it. However, so far the printer refuses to reinstall. I then got an error message saying that my USB connection had "malfunctioned" which confused me even more. Thinking that the USB mini hub was the problem, I uninstalled that but still no luck with the printer. I've even downloaded a driver from Lexmark's website to no avail. PLEASE can someone help as I have a beautiful printer which is now laying idle! My operating system is Windows XP and my printer is a Lexmark P4350 all-in-one. Thanks.

  Klof Ron 11:59 03 Dec 2005

Try connecting the printer directly to a usb connecter on the pc. Some hubs are not powerful enough to supply more than one component.

  jack 12:26 03 Dec 2005

1. Remove the Hub in Hardware manager
2. Delete the printer
3. Restart the machine
4. Re install printer software with printer
connected directly to machine.

Use hub only for low demand items -flash drives/media card reader and the like.

  Jackcoms 14:33 03 Dec 2005

Or replace your 4-port unpowered hub with a POWERED 4-port hub.

  khareji 15:14 03 Dec 2005

Sorry for the confusion but my printer WAS installed via the PC's USB port, not via the mini hub - added the mini hub recently and the printer was installed a couple of months ago. That's why I was at a loss as to why the problem arose. Still am going to try your suggestions (for which, thanks) and will get back to you.

  khareji 15:48 03 Dec 2005

Have done as Jack suggested but printer refuses to install. Help!

  Totally-braindead 15:57 03 Dec 2005

Forget the hub at the moment and disconnect it. I would suggest that first you check to see that the USB ports are installed correctly and working in Control Panel, then if alls well there try another USB device presuming you have one in one of the ports just to check it is ok. Then if thats ok try deleting and reinstalling the printer and then try it again, if that fails then I would suggest either the printer is faulty or the USB lead is faulty. PS make sure all other USB devices are disconnected when you do this, there is also the possibility that this is a power issue.

  khareji 18:29 03 Dec 2005

oh oh! have done as "Totally-braindead" suggested and tried another USB device in the USB port but it doesn't work. Gone into Device Manager and under device status it states "no drivers are installed for this device" and this goes for ALL my USB ports when I try a separate USB device! Now what do I do? Will I need to update the drivers or roll back, or what (bearing in mind I'm not a wizz)?

  jack 19:19 03 Dec 2005

Go into BIOS and make sure USB is enabled

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts