USB working in device manager but it seems Dead.

  The Rep 16:43 01 Oct 2003
Locked

Hello, my USB ports are playing up.
I tried to connect my printer last night, and inadvertenetly touched the USB cable end onto the metal back of the PC box. The computer powered down. I connected the printer and powered up. However the printer nor any other device are recognised by the USB ports. In device manager the USB ports are reported as working normally. The device all work on my laptop. I am using Win XP pro SP1.

Can anyone help here?

  woodchip 16:51 01 Oct 2003

You may have blown the fuse on the motherboard for the USB, you cannot replace as it's built in. you could try removing the USB in device manager and restart your computer and let windows reconfigure it when you restart comp. PS how did you try to connect your printer i.e. did windows ask for windows disc when you connected the printer. If so did you put the windows disc in, if you did that is the problem, you should have put the CD in you got with the printer.

  The Rep 17:03 01 Oct 2003

No the printer is a shared one that I switch between my laptop and PC.
It is already installed so no discs needed. I tried uninstalling the usb ports with no success.
If the fuse is blown, why does device manager report that all is well?

  -pops- 17:10 01 Oct 2003

"If the fuse is blown, why does device manager report that all is well?"

Because the fuse is placed at the end of the connections immediately before the output. As far as device manager is concerned, the USB hardware is OK.

I've had a similar fuse blowing happen to me. I bought a USB PCI card and used that instead. Only a few ££.

  The Rep 17:14 01 Oct 2003

ok thanks for that.
Is there really no way to repair/replace the fuse?

  woodchip 20:14 01 Oct 2003

No it's too small and it is part of the printed circuit

  graham√ 20:25 01 Oct 2003

In Device Manager, click on Power in USB Properties. If the fuse hasn't blown you should see the current being drawn by the devices connected.

  The Rep 08:30 02 Oct 2003

thanks guys for your advice.
I left the system over night, and I think the shoe elves have been in, because all seems well again!
Graham, I did as you said and the ports are drawing power. I wish I had checked that last night as now I dont even know what the problem was.... Maybe a static build up that dissapated overnight??

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Turn a photo into 16-bit pixel art

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?