usb weirdness

  johnny_frog 21:28 04 Sep 2005

I've got a USB problem which I would be be glad of some help with.......

I've got some sort of read problem using USB keys/memory cards etc. Anything I've installed (scanner/printer/webcam etc) works fine and dandy but anything that appears as a mass storage media (usb keys/memory cards) writes ok but reads as corrupted....

Everything comes up as ok in the configuration exclamation marks, everything functioning correctly; and it doesn't seen to be an os problem as I have the same problem in linux on the same machine....

I'd appreciate any assistance or suggestions anyone has.

Thanks in advance
Johnny Frog

  howard60 22:05 04 Sep 2005

I would try uninstalling the usb root and rebooting and then reinstall it.

  johnny_frog 19:02 05 Sep 2005

Thanks for suggestion howard60 but I've already tried that..... unfortunately with no result.

I'm currently playing with the usb settings in the bios to see if that does anything to remedy the situation.

Like I said in my first post the problem doesn't seem to be windows based as it's a dual boot XP/Fedora machine and I've the same problem in linux....

To me that would suggest some sort of hardware issue with the motherboard or a bios issue - although I'm no expert and will listen to any other suggestions.

thanks again


  Totally-braindead 19:07 05 Sep 2005

As a suggestion. Could it be a power issue? The USB can only supply so much power and if there are too many devices then they will fail to work properly, could you try disconnecting some of them and see what happens. If this is the solution then its cheap to get a powered external USB hub.

  johnny_frog 20:48 05 Sep 2005

Thanks for the suggestion Totally-braindead, but it ain't that either.... pulled out all the usb connections but to no avail, any file read from a usb key/flash card shows up as corrupt.

I've been through all the interations of...
Suspect PC in XP/suspect PC in linux/usb key/second PC/writing to key/reading from key...

and it's the suspect pc that the problem lies with...

I've been through the usb configuration settings in the bios

(The motherboard's an ASUS K8V-MX American Megatrends amibios version 08.00.09 revision 1007.001 for anyone that is interested)

with no luck - I did manage to switch all of the usb ports off (doh!) but didn't manage to fix the corruption problem.

  Totally-braindead 21:30 05 Sep 2005

How about trying different USB ports and see if that makes a difference. I assume that you know that the flash drive is acually ok ie it works in someone elses PC?

  johnny_frog 22:49 09 Sep 2005

Sorry for the delay in responding.... in a show of solidarity, my internet connection has decided to join the usb gubbins and down tools....

I may be reduced to an aldiss lamp and/or semaphor by the end of next week.....

Yup.... the usb key is good, been using it on other machine with no problems.... and I've tried the key in the front mounted usb ports and the rear mounted usb ports which are on the motherboard with the same result.....tears by bedtime

(sniff) I wish I had nice simple PC problems like other people; but no I have to have strange PC problems that the IT guys at work shake their heads at...... I must have done something REALLY bad in a past life

  Zion_Lion 23:55 09 Sep 2005

Maybe you could try a cheap pci usb card, if it works ok at least you'll have some usb connctivity until you get your problem sorted.

  johnny_frog 13:17 10 Sep 2005

Yup, that's an option although the "wierdness" is more of an inconvenience than a major problem at the moment.....

I do have usb connectivity for my peripherals (printer/scanner etc), the problem's only with usb keys and memory cards and I'm getting by using a mixture of email and CD's to do file transfers at the moment...

The PC's still under warrenty moment and the techician's coming out to replace the hard disc anyway (don't ask)..... I'd posted this more out of interest to see if anyone had had experience of this type of problem before.

Thanks to everyone for their assistance... if I get to the bottom I'll let you all know.

  woodchip 13:20 10 Sep 2005

What chipset is the motherboard as some provide updates if you are running XP

  johnny_frog 21:44 12 Sep 2005

Well I've done some digging and ASUS have done a sterling job updating their website.....

I have spent an evening with the back off the PC looking at jumper positions with the motherboard manual.... to no avail - no usb solution for the moment

However I have downloaded an updated bios and the gubbins that goes with it.

I am now in the process of plucking up the courage required to flash fry my bios (and my warrenty) to see if that helps any....

I'll probably wait until the weekend when the bairns are in bed and I've had a good drink before try this one... Listen for the bang, and if I haven't posted anything by monday then you'll know why.

so long and thanks for all the fish...johnny_frog

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique