USB Troubles

  Doragan 20:26 13 Nov 2007

A couple of days ago my USB ports stopped recognising my USB devices. When I went into device managerit said for all of the devices I tried that there were no installed drivers, even though I have used them previously many times. It also said that two devices, Plug in and play BIOS extention, and the AXSAKI SCSI controlled should be uninstalled and reinstalled. When I tried to do reinstall them it couldn't, saying that the INF was invalid.
I have never seen anything like this before. I am currently on XP SP2. Any help would be much appretiated.


  Fruit Bat /\0/\ 20:47 13 Nov 2007

Repair XP by replacing corrupt files

sfc /scannow

in the run box, press enter and let system file checker find and replace missing / corrupt file in windows and explorer.This will take awhile to complete and you may be asked for the CD to be in the drive if windows is not preinstalled on the hard drive.

sfc /scannow problems
click here

Then in device manager Action - scan for new hardware it should then reinstall all the USB port / devices.

  Doragan 21:04 13 Nov 2007

I ran the program, and it ran through with no problems at all. It took about 3-5 minutes. I then went to device manager, and the only option under the "action" tab was help. I clicked on scan for hardware changes but this did not pick anything up.

  Fruit Bat /\0/\ 21:52 13 Nov 2007

You need to Expand an item by clicking on the + the highlight an item then click action - scan for hardware changes

Or just reboot the machine it sould find new hardware on the reboot and reinstall

  woodchip 21:57 13 Nov 2007

Go to Device Manager and uninstall all USB then restart Computer it should sort the USB out auto

  Doragan 08:13 14 Nov 2007

I tried what fruitbat said, and it picked nothing up at all. Then I tried uninstalling the USB hubs, then restarting and they reinstalled ok, but still didn't fix it.

Thanks for your help so far though!

  woodchip 18:15 14 Nov 2007

Tru this remove all your plugged in USB items, switch computer off, remove the Wall Plug then press and hold the start button on the computer for about ten seconds. Start as Normal and test to see if they work

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?