USB stick has suddenly become 'read only'

  Florio 15:04 01 Aug 2014

My Maxell 16GB pendrive has suddenly and inexplicably become 'read only'; I cannot add or delete files, nor can I reformat the disk. I did manage to copy the contents onto the hard drive of my laptop, so losing valuable material is not the real issue here, but I'd like to be able to use the stick again, ideally after reformatting.

I know this is a common problem (and one that can often be fixed) because I've spent the last few days searching everywhere for an answer. There are in fact 7 or 8 solutions given on many websites, and I have tried them all, including changing registry entries, repartitioning the drive, downloading special software, and obviously trying to reformat. But I always get a message that the disk is 'read only. So if someone has had a similar problem, or has come across a solution that isn't commonly known, could they possibly share?


  BRYNIT 15:33 01 Aug 2014

Did you try formatting the drive from the cmd prompt click here

  Jollyjohn 16:12 01 Aug 2014

have you flicked the switch on the device?

Some usb drives have a tiny slider on the side that can set the device to read only to protect the contents.

  Florio 16:19 01 Aug 2014

Thanks for the replies, BRYNIT and Jollyohn.

Yes, I've already tried the things you've suggested (in fact all the possible solutions on the linked PC Advisor page).


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

Comment utiliser l’Apple Store Éducation ?