USB Soundcard woes - Completely unable to install drivers.

  LordSnot 05:59 20 Feb 2015

Hoping someone can help with this.

I've had a Sound Blaster X-Fi Surround 5.1 Pro USB sound device since 2010. On my old computer, running Windows 7 64 bit Home edition, there was absolutely no problem at all. I plugged it in, the system recognised it, I put in the CD that came with it, everything installed perfectly, the SB drivers installed, the system rebooted, it worked and that was that. Updates worked fine, all the latest drivers were fine. There was no need even to disable the drivers for the internal sound, the Sound Blaster happily allowed both sets of drivers to run concurrently.

Last Saturday I put together my new PC. It's an AND FX-8320 8 Core processor, Nvidia GTX 750 TI graphics card. The motherboard is an ASRock 990FX Extreme 3. 8 GB RAM, and running exactly the same copy of Windows 7 654 Bit Home Edition.

So far so good.

I installed Windows, installed the chipset drivers, installed the USB drivers, installed the graphics drivers. No problems so far, everything works fine. I did not install the drivers for the onboard sound.

I plugged in the XB X-Fi Surround 5.1 Pro. Windows detected the device, and installed some of it's own generic MS USB sound drivers. Now I could play back sound on my PC. So far, so good.

I put in the Creative Labs CD, installed everything, including the drivers. On restart, I had a blue screen of death. Restarted again, another blue screen.

In other words, the same install process I'd used loads of times on my old PC failed on my new PC.

Next thing I did was disable the onboard sound in bios. This made no difference, still a blue screen of death.

I rolled back the system to an earlier restore point, and tried the latest drivers from the Creative Labs website. These are the USBPCDRVLB102_0000 drivers.

I got an on-screen message:


Repeat attempts yielded the same result.

Some other checks I carried out:

Checked for IRQ conflicts, there are none, all is fine, as far as I can see, each device has a unique nuumber assigned.

Checked what sound drivers I currently had installed.

The current active drivers (put on automatically by Windows) ARE actually called 'SB XB X-Fi Surround 5.1 Pro'. However they are not Creative Labs drivers, and are not digitally signed by Creative Labs, they are Microsoft drivers.

In addition to this I also have two sound drivers installed by Nvidia during the graphic card setup. These are called:

NVIDIA High Definition Audio NVIDIA Virtual Audio Device (Wave Extensible) (WDM)

Not entirely sure what these do. I had something similar on my old PC, and just left them as they were. Not sure whether to uninstall or disable them on the new PC.

I tried to install the software that came with the X-Fi anyway, wondering if it might work with these drivers. It does not. No compatible device recognised.

So I'm stuck, and don't know what else to try. I can play sounds sure, but I want to install the Audio Centre, remote control, speaker setup etc. so that I can use all the features that came with it.

If anyone is able to offer help or advice, I'd be very grateful.

Thank you.

  xania 11:08 20 Feb 2015

I suspect that your PC has got confused by the various drivers. It might have been better if you had disabled the on-board sound card before installing the USB one. And make sure you don't install the sound drivers from you MB installation disc. Also some devices create problems if you u do things the wrong way around - some expect you to install the drivers before you plug in the device while others insist you do it the other way round - you will need to check your installation guide to check the correct process. Whether you can repair rather than start again is in the lap of the gods. You can try inserting the sound card into another USB port, but first I suggest boot into safe made and you ensure all the sound drivers have been uninstalled.

  LordSnot 17:39 20 Feb 2015

Right then, thanks for your help so far.

So I've just tried uninstalling all sound drivers in safe mode, even the Nvidia drivers, the installing the ones from the SB install CD.

Onboard sound is already disabled in bios.

Drivers installed ok from the disk, then instant blue screen of death.

It just doesn't like those drivers at all, really hates them in fact.

Still cannot install anything from the updated driver package, the usual 'SETUP IS UNABLE TO DETECT A SUPPORTED PRODUCT ON YOUR SYSTEM' message appears.

Finally, in desperation I formatted drive C and did a clean Windows install.

The manual for the SB states the USB device needs to be installed first, then drivers installed. Problem is, hooking up the device instantly installed the MS USB drivers. Not sure how to prevent this from happening.

I tried something else. Installed SB drivers from the CD first, then plugged in the device, and then updated the drivers from the CD.

Instant blue screen of death.

So.... I'm out of options sadly, unless anyone reading this has any suggestions?

  rdave13 18:07 20 Feb 2015

Latest downloads here.

Could be the drivers on the CD are old so try just using the latest. Another thing to check is connect to a USB 2 port not a USB 3.

  LordSnot 18:24 20 Feb 2015

Thank you but I already have the latest drivers, but am unable to install them.

There is the section of my original post that deals with this:

I rolled back the system to an earlier restore point, and tried the latest drivers from the Creative Labs website. These are the USBPCDRVLB102_0000 drivers.

I got an on-screen message:


Repeat attempts yielded the same result.

Also I have tried all of my USB ports, both 2 and 3, all with the same result.

Thanks anyway though :)

  LordSnot 19:04 20 Feb 2015

Something else too.

Been looking at my device manager and the various interrupts.

There's a (PCI) )X00000019 (25) High Definition Audio Controller there.

In other words an audio controller on channel 25, DESPITE me disabling the onboard sound in Bios, and also despite me not installing any of the onboard audio drivers.

Blue screens are usually caused by conflicts, right? So I'm now wondering what uninstalling this will do? Maybe the sound Blaster install isn't clever enough to differentiate, and also attempts to put itself onto channel 25? No way of knowing, as the blue screen prevents me from checking this.

Bit nervous about it, because I don't like messing with device settings when I'm not 100% sure what they are for... but perhaps it might be worthwhile to give it a shot.

  rdave13 20:06 20 Feb 2015

That's under system devices? Don't uninstall it just try disabling it for now. You should get the no audio device showing in the notification area. Clicking on the audio icon will start the 'detecting audio problems wizard'.

  rdave13 20:11 20 Feb 2015

Possibly the drivers are not compatible with your motherboard's bios/UEFI system.

  LordSnot 08:29 21 Feb 2015

@rdave13 It turned out those HD audio drivers were just the Nvidia ones. Disabling them did nothing.

Assuming the drivers are not compatible with my bios/UEFI, is there any method of fixing this, beyond buying a new motherboard?

  rdave13 15:47 21 Feb 2015

I would contact Creative help and support.Click here . They should get you up and running hopefully.

  LordSnot 08:04 22 Feb 2015

Tried that form, but it's mandatory to include a serial number, and I've no idea what mine is. I've had the device since 2010, so I've no longer got the box and documentation.

Ah well, I think I'm just going to give up. Can't think of anything else to try. I can at least use the device to playback audio if nothing else.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?