USB Problems

  [DELETED] 11:13 20 Dec 2003

System is Athlon 1.2 768Mb Ram with USB2 add on card running Windows 2K SP4.
USB 2.0 Root Hub Driver is Microsoft dated 19/06/2003, Version 5.0.2195.6717.

Connected to USB is Freecom HD-1 external HDD.
Everything works OK until I attempt to "Unplug/Eject Hardware" when error message is "Generic volume still in use".

I know that this is not so and that nothing is trying to access the HDD.

Any suggestions please

  Big Elf 11:36 20 Dec 2003

Is the 'Indexing' service running. Right click on the drive in Explorer and select properties. Take the tick out of 'Allow Indexing...'.

It could also be some other service running in the background like AV or system restore.

Whatever you were doing with the drive e.g. copying, saving could be buffered and are still completing.

  [DELETED] 11:51 20 Dec 2003

Indexing not running.

AV or any other running process does not affect problem, have tried by shutting down all running tasks in turn to solve problem.

  Big Elf 11:56 20 Dec 2003

I have the same drive but have it plugged in all the time. I've just tried to remove mine and I get the message 'The device....cannot be stopped right now. Try stopping the device again later'. However I also have a Toshiba PCMCIA hard drive and that is removed straight away.

I'll look at my settings in Device Manager and see if I can spot any differences in the way they're set-up and get back to you.

  Big Elf 12:05 20 Dec 2003

Curious. The policy for the Toshiba is optimise for performance and for the Freecom it was optimise for quick removal. I changed the policy on the Freecom to match the Toshiba and rebooted. I still get the device cannot be stopped message.

The only thing that I know is different about the Toshiba drive is that it powers itself down after a short period whereas the Freecom is constantly spinning.

I can't be of any more help at the moment.

  [DELETED] 12:27 20 Dec 2003

I've tried posting same problem to Freecom & Microsoft sites to see if there is a solution, so far no luck.

Gather from my son who works in IT that this is a problem with a multitude of removable HDD.

Will be interested to see if anybody comes up with a solution, perhaps it is due to fact that Freecom does not spin down.

Reason I want to unplug peridically is that I use the drive as a backup system via Norton Ghost 2003 for two machines.

  Big Elf 12:31 20 Dec 2003

Apart from powering down the PC I can't see a safe way of removing it. I'll be interested in the answer from Freecom particularly as they didn't reply to my email on another subject. Their Technical Support No. is 01423 704715. Be warned, they're a bit laid back.

  [DELETED] 14:34 20 Dec 2003

Been playing with other machine & Freecom device, noted that sometimes the device will uplug correctly (but not always) this machine has SiS USB chipset.
First machine has Via chipset and this never works.
Beginning to be fairly certain that problem lays with USB Drivers (i.e. Another MS glitch)

  Big Elf 14:49 20 Dec 2003

I also have the VIA chipset. From what I've read it's VIA not MS that have caused problems. You could try updating using Hyperion 4 in 1 USB driver but I installed that sometime ago and it obviously hasn't made any difference to my settings. click here

  [DELETED] 15:10 20 Dec 2003

Just in case I experience the same problem with the Via chipset.

  [DELETED] 15:00 21 Dec 2003

Still no answers from either Freecom or MS; but have been playing with Acronis True Image instead of Norton Ghost 2003, found the former program far superior to Ghost especially the latest Version 7.
Think I will change over permanently

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple