USB Problem

  daveac41 10:30 05 Mar 2010

Certain of my USB sockets appear to be malfunctioning, and nor recognizing hubs plugged into them. This has just started happening. Two USB's have External discs plugged into them - these are fine. What could be the problem with the others, please

  Batch 11:47 05 Mar 2010

What sort of PC is it (i.e. desktop, laptop) and whereabouts on the PC are both the working and the non-working sockets?

  daveac41 12:59 05 Mar 2010

Hi, Batch,
It is a Desktop, with two sets of two USB sockets at the rear, and a pair of USB sockets at the front. The External drives are plugged in at the rear, and a mouse at the front. The fault seems to be with hubs. Although they have worked before.. they won't now.

  Fruit Bat /\0/\ 15:35 05 Mar 2010

Might be worth refreshing the USB ports

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  Batch 16:26 05 Mar 2010

If you're saying that the hubs are plugged into the front (and that that is where the problem is), it could be a dodgy connection.

The USB sockets on the rear tend to be directly mounted on the motherboard. Sockets on the front are often connected via a cable to a point on the motherboard. It could be just a poor connection. This would be consistent with the rear-mounted ones still working OK. You could try unplugging and reconnecting (at both ends if there is a plug at both ends) - it could do the trick.

Having said that, it might be worth trying Fruit Bat /\0/\'s suggestion first.

If you do intend to dig around inside the cabinet, make sure you discharge any static from yourself first, beware of what you touch and follow electrical safety rules.

  Bris 19:20 05 Mar 2010

If a device other than a hub works OK in a socket then that implies that the socket is OK. If a hub is non powered then it will draw current from the socket it is plugged into and distribute it over the 4? ports on the hub thus you have a quarter of the allowed current at each port. As each port has a current limit and if you exceed that limit it will stop working. My guess is that you have too many devices plugged in. To check this remove some of the devices in the rear ports and see if the hubs spring into life. If the hubs are powered make sure they are connected to their power supplies and if they are please disregard this post.

  daveac41 23:10 05 Mar 2010

Thanks all. I'll try Drive Cleanup.
Batch- I've used all at varying times before - never had all six going at once though. Hubs only use to give extra lengths of cable, though, not for multi USB's!

  daveac41 09:38 10 Mar 2010

Hi, all. I tried Drive Cleanup-it worked OK. All my USB-connected devices work, with the exception of the Hubs. There are three of them, bought at different times.None of them operate correctly, so I can only assume that some Windows update affected them - as they used to work, as did my USB SD card readers.
Thanks again for all assistance.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

Best Mac video editors

Idées cadeaux pour geeks et tech addicts