USB Printer Port not Recognised

  [DELETED] 12:11 16 Aug 2003

OS WinMe\Printer Epson 890

My Pc will no longer print to this usb port, the printer properties|details states "Epusb1-Unknown local port" I have removed and re-installed the software and dowloaded the latest drivers.

The printer has been tested on 2 other pcs without any problems. The system recognises the usb ports for my Laser printer,scanner and digicam (now all un-installed) I have also tried a restore.

Any suggestions please?

  [DELETED] 12:17 16 Aug 2003

Have a look here and see if that is any help. click here

  [DELETED] 15:00 16 Aug 2003

spensus May I reinforce what pj123 has advised.My Epson 925 has been an absolute pig at times even when loading software first. It is essential that you remove all previous traces, then load software and only switch on printer when told to on screen

  woodchip 15:26 16 Aug 2003

When you installed the printer did Hardware wizard ask for Windows disc? did you put it in.? IF so that's Why it does not work

  [DELETED] 15:31 16 Aug 2003

Yes, I have tried your suggestions to the letter,but still no go. The printer was working fine the last time I used it. Im wondering if some software Ive installed may be the cause.

  [DELETED] 15:40 16 Aug 2003

The printer hasnt just been installed, its been ok for 14 months

  [DELETED] 16:01 16 Aug 2003

Have you by any chance shifted the printer to a different usb port? Printers like to be on the main usb connection from the M/B. One of the two usually on the main panel at the rear of the PC - not on a usb hub, powered or otherwise. Using my Epson 740 on a previous Me O/S. I was getting exactly the same problem you mention but this was on initial install. It just would not connect on the USB port. I eventually solved the problem by purchasing a USB to Parallel adaptor and using it via the adaptor. If I remember correctly it then worked okay listing the port connection as USB1 on LPT1. Stayed like that until I shifted the printer to an XP printer and works okay here on USB using the W2000 drivers. Never did find out why it wouldn't work on ME using the USB connection.

  [DELETED] 16:22 16 Aug 2003


I did try the other ports on the pc after the printer stopped working,but to no avail,and its now back on the main panel. Your adapter suggestion may be worth a try,but I will keep this thread open for a while longer

  woodchip 17:50 16 Aug 2003

Try this remove Printer from Add Remove Programs, Remove all USB from Device Manager and restart computer without the printer connected. Allow Windows to configure USB before connecting printer, connect printer and switch on, when Hardware Wizard pop's up to say new hardware found cancel it, then put the printer CD in and load drivers and software. Before doing the above also make shure you remove printer folder from Windows Explorer

  [DELETED] 18:34 16 Aug 2003

I have tried what you suggest but when the hardware wizard pops up to say new hardware found the text is in a small box with no the option to cancel,it then continues to open WinMe

  woodchip 20:35 16 Aug 2003

Then do the above but do not restart windows, instead go to Control Panel Add New Hardware and when you click the wizard to run choose not to let windows search for hardware but click ?have disc? then point it to the ?cd with the printer files on?, you may have to brows the CD so windows can see the driver watch the OKAY it will not be active until it thinks it see's the driver, then you can press OK if it loads, then restart computer to let it sort the rest of the USB out

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple