USB Printer defaults to LPT1

  Drifter 00:53 19 Nov 2003

Hi, have loaded '98 onto a PC with only USB2.0, usb printer defaults to LPT1, there is no EPUSB1 in the drop down for printers Properties. So I have installed a PCI card for USB1.0, exactly the same effect. Drivers are loaded for the new PCI card, Epson drivers loaded, it detects the printer when switched on but cannot confirm the printer port.
All worked well with XP home, untill a big crash and lost everything, no XP disc, so loaded '98.
Is ther something in BIOS that could be causing it. Have checked usb cables and changed to Epson 860, this prints fine in parallel, but the printer that belongs to the PC is an Epson C44UX - USB only -
Anyone got any ideas. Thanks

  gold 47 01:33 19 Nov 2003

What version of W98 do you have??there are patches
you can download for USB which will improve the USB in W98SE

  Spencus 01:49 19 Nov 2003

Wish I could help...Ive got the same problem with Win Me,I get "Epusb1 unknown local port" in properties,Ive even tried reinstalling Win Me,Like yours the printer is dual port,So I can use Lpt1, whats annoying is its ok on other Pcs

  Drifter 03:18 19 Nov 2003

I'm using '98 SE. It all worked well with XP. Can't understand why it can detect the printer on the end of the USB cable, but won't find the printer port it is connected to. ARRRRRRRRRRRRRRRR
Have downloaded all updates for 98. Stuck for time being

  hugh-265156 03:40 19 Nov 2003

have you the latest drivers for the printer installed.

the esupport tool click here? may give you a few things to try.

i went through it with your problem (selected uk/44ux/ and driver instalaton issue/usb)

when clicked "no" when asked to select "EPUSB1" it suggested a new cable/drivers may help.

have you tried using "etalk" click here#

  Drifter 11:31 19 Nov 2003

thanks for the links. Will try the new drivers tonight, but don't hold out much hope, the printer is only 2 months old, if it needs new drivers now, that's a pretty poor show, I think reinstall win98 is called for or buy XP.

  reddwarf 12:24 19 Nov 2003

I had a similar problem that was resolved by uninstalling the usb drivers using the utility that came on the printer installation disk. This fully uninstalls the drivers so that you can start the driver installation from scratch again.

The problem for me was using WinME but I would think the principle would apply

  jimv7 12:34 19 Nov 2003

A simple remedy is to install the epson drivers correctly, and follow the install instructions.

If you do not the printer will default to lpt1 port.

Do not connect the printer, first run the drivers and during the install it will ask for the printer to be connected to the usb port, after talking to the printer it will install correctly.

  Drifter 12:51 19 Nov 2003

That's exactly what I've done. But when it asks for the printer to be switched on, it stays "SEARCHING" and I have to click CANCEL. Have loaded & unloaded several times. Tonight I will try disable the MoBo USB support(USB2.0) and try again with the PCI card USB1.0 Ports.

  hugh-265156 14:08 19 Nov 2003

i had this problem with the driver on my supplied disc.

just hangs when searching for printer.

never got the drivers from the disc to install.

downloaded "the same version" from the epson site(win2000) and worked first time.printer was a c42+ on win xp.

  Drifter 23:58 19 Nov 2003

The thing is this printer installed OK, first time with XP, the problem is only since we lost XP and loaded W98SE. Have decided to buy XP, probably for the best since support ends in Jan 2004.
Cheers and thanks for all the help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?