USB ports not recognising mass storage devices

  Quiet Life 15:13 24 Dec 2011
Locked

I am running a dual boot XP Home and W7. Yesterday I copied files onto an HP media drive which connects to USB inside the PC and also to a flash drive connected to one of the two front USB ports. Having transferred the files to another PC I reinserted and found that the mass storage devices were no longer recognised and this also applied to all the other USB ports. Other devices webcam, mouse and keyboard were OK in any of the ports. Googled the problem and tried many suggestions without success. I had an old USB hub and connected that and mass storage devices worked if connected to the hub. I got the message that the devices would work quicker if connected to other ports so I assume the Hub is only USB1. I rebooted to W7 and the position was exactly the same mass storage devices not recognised. I believe it must be something in the bios as both systems are similarly involved. Any one with experience of this problem?

  Quiet Life 13:39 29 Dec 2011

I have come to the conclusion that the PHY layer for USB 2.0 in the chip has failed. This can fail leaving USB1 working OK. Unfortunately testing of the USB module requires sophisticated equipment to prove the mobo is faulty and it is likely only the manufacturer will have this equipment

  Quiet Life 19:10 30 Dec 2011

Before disconnecting the mobo for return to sellers (fortunately still under warranty) I fitted a new hard drive and installed a different version of XP SP3. USB2 devices still not recognised. I think it is now conclusive the mobo is faulty

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S10 review

Butcher Billy's Black Mirror artwork is coming to vinyl for the first time

Is the Apple Store down? What's Apple launching?

Comment modifier le DPI d’une souris ?