USB ports not recognising mass storage devices

  Quiet Life 15:13 24 Dec 2011

I am running a dual boot XP Home and W7. Yesterday I copied files onto an HP media drive which connects to USB inside the PC and also to a flash drive connected to one of the two front USB ports. Having transferred the files to another PC I reinserted and found that the mass storage devices were no longer recognised and this also applied to all the other USB ports. Other devices webcam, mouse and keyboard were OK in any of the ports. Googled the problem and tried many suggestions without success. I had an old USB hub and connected that and mass storage devices worked if connected to the hub. I got the message that the devices would work quicker if connected to other ports so I assume the Hub is only USB1. I rebooted to W7 and the position was exactly the same mass storage devices not recognised. I believe it must be something in the bios as both systems are similarly involved. Any one with experience of this problem?

  rdave13 16:06 24 Dec 2011

I don't know if you've seen this thread but the solution in 'the solution is so easy by jaybeef - 10/17/05 1:00 PM ' post seems to suggest removing all usb peripherals out side of the case, shutting down and remove the power supply. Instead of waiting a for 30 minutes I would then press and hold in the power switch for a minute or so. Reboot and connect your USB devices one after the other. Worth a try anyway.

  woodchip 17:05 24 Dec 2011

As rdave13 the Drivers have got corrupted and capacitors are still holding a charge with the info. that why they need charge removing as above from the motherboard

  Quiet Life 13:58 25 Dec 2011

Thanks for above but regret did not work for me. Have also reinstalled MOBO drivers but problem still as posted. Why mass storage units only recognised when through a usb1 hub a mystery. Will reset bios and see if that helps meantime solution welcome

  Quiet Life 17:13 25 Dec 2011

Resetting bios and reinstalling mobo drivers did not sort the problem.

  Fruit Bat /\0/\ 21:13 25 Dec 2011

Use Drive clean up to remove USB device drive info from the registry or In device manager Uninstall EVERYTHING under the heading USB, reboot the PC let XP find and install new hardware. Your equipment should now be recognised.

  Quiet Life 14:51 26 Dec 2011

Thanks Fruit Bat but did not work for me. It is odd how mass storage units fail to be recognised on an other version of XP and W7 which I have on the same PC if entered into USB ports but will be recognised if entered through a USB1 hub connected to these ports. This all happened at the same time and would seem to point to some hardware problem but it is a mystery. I am going to purchase a USB2 hub and see what how they work on that.

  Quiet Life 19:01 26 Dec 2011

The USB2 hub lit up but was not recognised and thus any storage device connected to it did not show. I tested the hub on an other machine and it was immediately recognised as a USB2 hub. It is looking more like the problem is hardware related and USB 2 devices are not recognised.

Any more suggestions?

  Fruit Bat /\0/\ 19:54 26 Dec 2011

Checked USB settings in BIOS?

  rdave13 20:53 26 Dec 2011

If it's an Intel board then have a look here.

Wondering if there's a conflict between both OSs for the mobo?

  Quiet Life 19:13 27 Dec 2011

Updated bios to latest available and also downloaded and installed latest chip drivers. All usb items, including the USB2 enhanced host controller, are shown as OK. Unistalled them all again, disconnected everything reset bios took out cimos battery , left for several hours and restarted. Entered bios and checked all USB including high speed USB were all correctly enabled. All the USB controllers were installed on start up and all said to be working OK. Position remains unchanged and USB2 devices not recognised. Anybody know how the hardware on the mobo works for USB2 as there seems to be little else that can cause this malfunction.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Shadow of the Tomb Raider review

Julian Glander recreates your art school experience in quirky video game Art Sqool

iPhone XS vs iPhone X: What is the difference?

TV & streaming : comment regarder la Ligue des Champions 2018-2019 ?