USB pendrives no longer opening even if I get icon in the taskbar

  Florio 15:55 16 Sep 2014

Hi. Until recently my laptop was working perfectly, but as of this morning it will not open any of my USB pendrives; when I insert a pendrive the little icon with the green circle and white tick appears in the task bar, but the disk does not open or appear in Explorer Resources. I have already installed and run DriveCleanup.exe. Did a reboot, inserted a couple of USB pendrives and my laptop began installing the necessary drivers. At that point I thought that my problem had been fixed, but basically nothing has changed. One thing that may be important: the other day I had to change my laptop battery, and I hadn't had to use a pendrive until this morning. I read somewhere that the battery can have something to do with USB pendrives not being recognised. All advice willingly accepted! Florio

  Woolwell 16:20 16 Sep 2014


  Florio 22:13 16 Sep 2014

Sorry, should have stated that. Windows 7 Home Premium

  Bob 64bit 07:35 17 Sep 2014

I have the same problem. See my post Monday of this week when I stated that the sd card no longer worked. Have just tried out the usb pen card and have the same problem.

Perhaps there is someone out there who can assist us and perhaps many more who have yet to test their pen drives.

Bob Extere

  Woolwell 09:51 17 Sep 2014

I had a problem about a year ago when an sd card reader (internal) did not work. For some reason it had lost its drive letter. I fixed it by going to and assigning it a drive letter. Windows 7 Disk management. It may or may not work for you.

For the USB problem check through device manager that there aren't any problems there and possibly refresh the driver. I would not have run drivecleanup.exe but would have tried system restore to just before the problem began.

  onthelimit1 11:07 17 Sep 2014

I had a similar problem on an Asus last week where non of the USB ports would be recognised (got the 'bong' sound when something plugged in, but not appearing in My Computer). Gave up in the end and took the hard drive out, stuck it in a caddy so I could save data to my PC, then did a restore to factory settings. Not only do all ports now work, but the laptop is much faster.

  Florio 16:02 17 Sep 2014

Thanks guys for your replies.

I can't really change the letter of the drive, because my laptop doesn't acknowledge the drive in Windows Explorer. Really strange, as there is the icon in the notification area of the task bar, and the name (brand) of the disc is displayed in devices and printers (Control Panel).

Can't do system restore because I'm not exactly sure when the problem must have begun, and in any case I have few restore points since I use CCleaner and ASC.

I would hate to have to a factory reset.

I perhaps should mention that apart from the new battery I installed last week, I also updated my BIOS around then (for the first time since I'd bought the computer). In addition I have just bought a new all-in-one printer which means new hardware drivers added. The printer actually 'created' a new drive 'Z' which I have hidden. And to top off everything, last night I got a blue screen with a 'Driverirqlnotlessor_equal' message. First time ever. I was so surprised I forgot to take down all the details.

Anyway, all advice willingly accepted!


  Woolwell 16:41 17 Sep 2014

I'm suspicious of the BIOS update. A BIOS update is IMO rarely required unless you have problems already. Are the USB ports activated?

  Florio 22:16 17 Sep 2014

How do I check that Woolwell?

  Bob 64bit 14:14 19 Sep 2014

Further to my post last Monday I have had similar problems with SD Card and USB. I did try all the suggestions ie System Restore Scannow etc but without success. I have just completed a restore to factory settings and the rig is now working to perfection. As a matter of interest the "knoweverthing"grandson came to stay with parents with parents while we went for a short holiday.......wait for it.he used this rig and downloaded a"dubious" system cleaner with dire results.....Here endeth the lesson Bob Exeter

  Fruit Bat /\0/\ 18:47 19 Sep 2014

With just one of your USB sticks plugged in, Open Device Manager.

In Universal Serial Bus controllers look for Mass Storage Device and select it. Open it's "properties" and select the "details" tab. Click the down arrow and look in the drop down list for anything to do with Lower or Higher Filters. Note any such name/value pairs you find.

If you have any filters on the usb mass storage device it will stop it from working.

Open Regedit and search the complete registry for the "value" found above. You want an entry where it is used as a lower or higher filter.

Delete any such lower or higher filter entries found in the registry. probably in


Use F3 to find next occurrence to make sure there are no others.

Repeat for all filters.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

See how VFX studio Rise created 'Jabariland', holograms & digital doubles in Marvel Studios' Black…

Best Android emulators for Mac

Comment importer des contacts d’un iPhone à un autre iPhone ?