USB not recognised

  nuhim172 11:32 24 Sep 2008

I am have a rather annoying problem. I have a wireless Belkin USB device to allow me to connect to internet (BT home hub). But now i am constantly, when inserting the USB, receving a pop-up say USB device "not recognised" or "device has mulfunctioned". When i open up device manager i see "unknown device" in one of the ports.

click here

I think i figured out the problem but cant find the solution. When i tired to connect to the internet the connection failed. And a windows message popped-up saying "connection failed" and then gave me the option to "repair connection" - stupidly i clicked repair connection. Whilst trying to repair the connection windows disabled the device then tried to enable the device but was unable to "enable the device". How can i manually enable the device?

  Halmer 11:38 24 Sep 2008

My Computer right click
Device Manager

  baldydave 11:47 24 Sep 2008

Try as halmer says above also try reinstalling the usb driver,again using device manager route then pick install driver.It may be that it has totally failed,I have seen this happen many times with usb network sticks if you wiggle it about you may get a connection which indicates a break inside the stick. I find PCI cards are a better option.

  nuhim172 16:59 24 Sep 2008

Have tried that doesnt seem to work. When i open device manager with the USB inserted the only option it provides are to disable, update driver or uninstall. I disabled and enabled but had no effect.
Any other ideas??

  Woolwell 17:06 24 Sep 2008

I have found that Belkin usb dongles are quite fussy about which USB port that they are put in. They prefer to use the same one every time. Have you tried yours in a different port?
Otherwise you will probably have to uninstall the Belkin software and reinstall.
Which OS?

  nuhim172 17:17 24 Sep 2008

Its been working fine in the port that i ve used time and time again. But that particular port doesnt work nor does any other ports for the belkin usb. If i put a any other usb device into the port no problem.

  Woolwell 17:23 24 Sep 2008

Alternative to uninstall and reinstall is a system restore back to before the problem.

  woodchip 17:26 24 Sep 2008

Plug the adapter in then Go to Device Manager and remove "unknown device" Reboot computer without Adapter and then Plug it in

  nuhim172 17:54 24 Sep 2008

i tired that but nothin. I've just notice in the network adapter section of device manager i dont see the belkin usb adapter only: Intel(R) POR/100 VE Network Connection. In the past the device has alwasy been visible in this section. how do i make it re-appear?

many thanks for the advice.

  woodchip 18:02 24 Sep 2008

The not recognized on will stick out like a sore thumb in Device Manager, Not forgetting its a USB

  woodchip 18:03 24 Sep 2008

PS have you loaded the Driver Software for it First? as that is what you should do. Before plugging the Adapter in

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Artist Helen Friel on designing paper models for everyone to make

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts