usb mouse/laptop problems

  tonyq 17:26 09 Sep 2008

Hi all,
I have been having problems with my mouse (optical usb) while using my Toshiba laptop (Vista). I could only get it to work in one usb port although this was intermittent at times. Thinking that it was the mouse that was the problem I bought a new mouse, only to find that I am having the same problem, I can use the new mouse in one usb port all be it that it is a different usb port than the first mouse. I have tried a few system restores to no avail. When I try in a different port it tries to find the appropriate software without success bringing the following message up on screen.
click here

  tullie 17:40 09 Sep 2008

Can you delete everything in control panel to do with USB,reboot and let windows reinstall.You will find them in System/Device Manager,might solve the problem.

  tonyq 17:58 09 Sep 2008

have tried your suggestion to no avail thanks anyway.

  Fruit Bat /\0/\ 18:40 09 Sep 2008

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here

  tonyq 19:17 09 Sep 2008

Thanks Fruit Bat /\0/\ but still no luck.

  Ditch999 20:57 09 Sep 2008

If it has always been a problem try different usb devices in the ports to test them all.

Also check that usb (both versions) is enabled in the bios.

If all checks out ok then see if there is Legacy USB support in the bios and enable it.

  tonyq 11:33 10 Sep 2008

I think the problem only started a few days ago,thinking it was the mouse that was the problem I replaced the mouse only to find I still had the problem. I have tried a usb pen drive/memory stick (not to sure the correct name)in all of the usb ports and all work o.k. so can I take it from this that the problem lies with something else not the usb ports?. Is there anything else that could be causing the problem?

I have never had any dealings with regards to the bios so am a bit reluctant to delve into that area only as a last resort so I may get back to you on that one.

  jack 12:00 10 Sep 2008

Skittish to say the least.
Whilst in my case several printers, a scanner, a track ball, all perform without a murmur [all digits crossed] these last day USB headphone/mic., set managed to 'lose itself' just when I was about to record a dialogue fora slideshow and had to abandon the idea.
Thinking it was the on board sound card ReelTek AC97- I roll back driver, took program out put it back again etc., etc , all to no avail.
Then yesterday whilst doing something else entirely
I got the 'Found new Hardware' balloon up, then installed and working- and the phones were back and I had not done a thing.

  tonyq 16:08 10 Sep 2008

I have now tried 3 different mice and having problems with all 3 of them so I presume it's not the mouse at fault.

  Ditch999 16:10 10 Sep 2008

Open a command prompt by going Start>Run>cmd

At the command prompt, type "set devmgr_show_nonpresent_devices=1" (without quotes) and press Enter. You won't get a prompt in response; the command prompt will stay blank.
Using the same command prompt, type "start devmgmt.msc" (no quotes) and press Enter. The Device Manager will launch in a separate window. Now, enable the Device Manager to show ghosted devices by clicking View then Display Hidden Devices.

Look for all entries relating to USB HID devices or mice/keyboards and uninstall/delete them

  tonyq 18:03 10 Sep 2008

did what you suggested still no luck.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?