USB Motherboard Header

  meathook 01:22 28 Feb 2006

My motherboard has a header for two USB ports. The pinout is as follows:
USB 1 1x 2o 3x 4x 5x
USB 2 1x 2o 3x 4x 5x

According to the manual: Pin1 - Vcc
Pin2 - Key: no pin
Pin3 - Data -
Pin4 - Data +
Pin5 - Gnd

I wanted to use these two ports so I bought a dual port header cable(though with a single connector)from Maplin. Thinking they were standardized and generic I plugged it straight in.

The mouse I wanted to use in the USB port would only show up as an unknown device with a yellow exclamation mark in Windows 98, and only when in one of the two ports. I took the connection out and tried the other way round but got the same result. Power of some sort is getting the ports because when I plug in a USB led light, it works.

A bit of diggin on the net and I realize I should have rewired the connector to match my Mobo pinout. Straight out of the box it was wired as such: - Black
- Red
- White
- Green
- Black

There was no indicator as to which was pin1. The wiring for port two was the same.

I swapped round Pin1 and 2 so it was Pin 1 red, black, white, green, black. Same problem. I reversed the connector so it was Pin 1 black, green, white, black, red.

Last thing I've tried was to swap the two black wires with each other in case the ground black wire was going to the absent pin 2.

Still can't get my USB mouse to install. PC recognises an unknown device is attached to the USB bus but that's as far as it will go. I've tried software fixes without sucess so I'm pretty sure it must be hardware problem with the wiring.

Mobo is a QDI P51430TX Titanium IB.

Thanks is advance for any help.

  keith-236785 07:31 28 Feb 2006

the yellow exclamation mark is telling you that the USB drivers for your mouse are not installed, if you have an install disk for the mouse, try putting it in and see if it autoruns, that might allow you to install the needed drivers and setup the mouse. windows98 does not have native usb drivers, you need to install them for the items to work.

try unplugging the mouse before putting the cd in.

good luck.

ps, a typical USB connection on a mobo has 9 pins, 5 on one row and 4 on the other.

the extra pin is not used so dont try searching for a missing wire.

red, yellow(or white), green, black is the correct taken from left to right. at least it is on mine.

hope this helps, good luck

  martjc 09:05 28 Feb 2006

...sorry to tell you, but there may be a major problem here. On many motherboards pin one of the USB header is not marked, though there should be reference to it in the manual. The problem could be if you DID wire it up backwards, there is a potential for permanent damage on the motherboard - you may need to get a PCI usb card.

paperman27 is right. MOST usb headers are wired in this way. But that's no help if you can't find pin 1, is it. Usually, if you look at the header with the 5 pins on the top line, pin 1 is to the left. But as these things are not standardised, who knows???

  Eric10 09:22 28 Feb 2006

This is one of the best sites for USB information click here. Read the warning on the page as it backs up martjc's comment about possible damage. This is only one page on the site so it may be helpful to browse the rest of the site also.
On identifying pin 1, since pin 2 is missing in both rows it should make it fairly obvious.

  jimv7 09:34 28 Feb 2006

On most motherboards pin 1 of the header is marked with a slightly thicker white line.

  meathook 14:26 28 Feb 2006

Assuming the manual is right it's no problem identifying pin1 on the header since pin2 is missing in both rows, as Eric10 says.

What I was getting at was the header connector from Maplin had no indication(or keying)of which way to attach it to the header. It fitted either way. I'm aware that I could have done damage to mobo header or USB connector but there still appears to be power getting there, and if I plug in USB mouse it recognises an unknow device on the bus.

On drivers, according to Microsoft's knowledgebase all I need to have is Hidclass.sys in the right folder for the Intellimouse Optical to work. The MS site makes no reference to specific drivers for the mouse even for using it under Windows 98.

I've emailed Maplin to ask them about their colour coding for the USB bracket wiring.

Thanks to all so far.

  Fruit Bat /\0/\ 15:47 28 Feb 2006
  meathook 20:03 28 Feb 2006

The USB header on the picture you've linked to is different to my USB header. Where as it only has a missing pin on the column, on both columns I have a missing key pin on the second from top i.e. xx
where the 0's represent no pin.

This means pin 1 for each USB port must be the top one preceding the empty pin.

Thanks again.

  keith-236785 20:13 28 Feb 2006

have you tried the mouse in the onboard USB sockets on the back of the mobo (if there are any), at least that way you would determine if its the mouse thats at fault.

as suggested, a PCI USB adapter card would work but i can appreciate the fact you want to get the header working.

one last thing, have you checked your mobo bios for any settings relating to USB, it might be that the usb has been disabled in the bios, hence the yellow exclamation mark (although i dont think the mouse would show as connected if it was disabled)unlikely but worth checking anyway.

good luck

  keith-236785 20:28 28 Feb 2006

just checked out your mobo manual, ignore the onboard usb bit, your board doesnt have any.

i think your best option would be the pci-usb card, and finally, what version of windows are you using, with such an old board, windows from 98SE upwards supported USB, earlier ones didnt (or didnt very well). if your win98 is the first version then maybe thats the problem. i dont have (and never had) the win98 first edition so cant comment.

worth considering before paying out for a USB card.

  meathook 21:35 28 Feb 2006

Thanks paperman27. There's nothing in BIOS specifically for USB though I've ensured plug and play OS option is enabled. I've been through everything else in the BIOS with a fine toothcomb thinking of things like IRQ assignments, ensuring power management is OS controlled etc.

The system(not actually mine anymore - I'm trying to sort this for someone else)runs Win98 and the mouse I'm using to test the port is definitely good - it's the mouse I use on my system. As you've probably realised it's an older AT based PC and the serial rollerball mouse had become so erratic with age hence the need to find an alternative. There is actually a PS/2 header on the mobo which would have been my first choice but I couldn't find a header cable for it anywhere. I looked at PCI USB cards but thought I'd save a few quid and use the headers that were already there. Looks like I'll have to try that anyway now.

According to MS website, Win98 suuports USB as well as Win98SE. The host controller and root hub show up fine in Device Manager so do you agree that it seems to be a hardware problem - either with the mobo header or bad cable/ports I'm trying to connect - rather than software?

Definitely need to go buy a wig.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)