USB Memory stick Says it is write protected, now cant use.

  Sparkly 19:47 28 Apr 2012

Hi i am trying to clear out some folders on the above and copy otherstuff to it but out of the blue my Transcend 8gb memory stick tells me "The Disc is Write Protected and i need to remove the write protection first, i have not protected it in any way it has just started to do it by itself, i have tried formatting it but get the same dialouge box each time. Does anyone have an explanation/way round this. I have looked at the stick and there is no sign of a switch to lock it/protect it.

  Fruit Bat /\0/\ 21:04 28 Apr 2012

Write Protected?

go into command prompt then type "diskpart" type "list volume" then "select volume xxx" (where xxx is the write protected problem drive) then type "attributes volume clear readonly"

Then exit command. Then try to write to the drive.

  Sparkly 09:45 29 Apr 2012

Morning Fruit Bat /\0/\ done as you advised but sorry to say to no avail, tried writing to it but just get the spinning blue circle "Not Responding" tnanks anyway.

  KRONOS the First 09:54 29 Apr 2012

Can you try the drive on another PC? and what is your operating system by the way?

  finerty 10:01 29 Apr 2012

R U sure there is no movable click button on the stick itself you could of accidentaly pushed, have a good look at the pen, some pens have this little push slider on them that lock the drive from use.

  Sparkly 11:05 29 Apr 2012

Hi Chronus have switched in between a Vista macine 32bit and W7 ultimate 64bit with the same out come, Hi finerty there is a slider on the side of the stick but that is for retracting the USB connector inside the stick nothing else. I will try it in a laptop when my son arrives.

  Forum Editor 11:48 29 Apr 2012

try this:

Make sure you know the drive letter assigned to the stick.

Shut-down your machine.

Insert the Memory Stick. Turn on and start pressing the F8 key

Select Safe Mode with Command Prompt

Type C:\windows\system32>G: and press enter

Then type G:>format G: and press enter

Press (Y) if prompted and press enter

A full format will start and the write protection will be removed.

Obviously you'll lose all files from the stick.

  robin_x 12:18 29 Apr 2012

FAT32 also has file size (max 4GB per file) and number of files limits.

I wouldn't expect to get a Write Protect error but bear in mind.

I have problems with a 512MB card for a Photoframe which cops out at 200 small photos for some reason, even though it's nowhere near its limit. (Root location of files and filename length taken into consideration).


If you don't need FAT32 for use on other devices/equipment and only use on Windows PC, try NTFS format instead of FAT32.

  Sparkly 15:50 29 Apr 2012

Hi Forum Editor thanks for your help did as you suggested but get this message after cliking enter "Then type G:>format G: and press enter " I get J (my Disc) is not recognised as an internal or external command operable programme or batch file. Getting the hammer out soon.

robinofloxley have tried changing to NTFS but still the same.

  rdave13 16:25 29 Apr 2012

It looks as the drive has failed. Do you have a hard drive manager program? If so try wiping the drive first. Remove safely, then reconnect and using the program force a reformat. If that does not work then it is more than likely come to an end.

  lotvic 16:45 29 Apr 2012

Try the registry edit, Navigate to the following registry key: HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies. Change the value for the key "WriteProtect" to 0

or you could d/load the .zip for JetFlash recovery from transcend website. Direct d/l link on thread

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Comment savoir si quelqu'un a bloqué votre numéro de téléphone ?