USB memory stick

  sil_ver 13:32 17 Mar 2007

PCLine 1GB memory stick worked fine until today. I wanted to copy an app to it but it says 'write protected' then I tried to uninstall another prog from it with the same result. Any ideas how to overcome this problem?

  VoG II 13:33 17 Mar 2007

Has it got a little switch to make it protected/unprotected?

  Technotiger 13:33 17 Mar 2007

Hi, some mem sticks have a little slide on the edge which is movable to protect/unprotect, have a close look.

  sil_ver 14:03 17 Mar 2007

No switches on drive

  Technotiger 16:56 17 Mar 2007

Hmm, with stick in slot, have a look in My Computer and right-click on stick's icon - look at Sharing and Security. You might have set it up by accident?

  Robotic_Rob 17:10 17 Mar 2007

I think you can protect the memory stick using software as well. As with the software i use with my memory stick you have an option to write protect it.

A file register/file in the memory stick might of gone corrupt making it think that's its on write protect. A format might solve it.

  sil_ver 19:01 17 Mar 2007

I wanted to reformat but it wont let me. Looking at 'Sharing' tells me nothing

  Technotiger 19:15 17 Mar 2007

I have done a bit of research via Google, it appears that others have the same problem, but unfortunately no one seems to have come up with the answer to it.

Sorry I can't help you further.

  woodchip 19:19 17 Mar 2007

If you can right click on the Stick in My Computer then Properties See if you can see a little Write Protect box with a tick. Remove it then press ok. check tabs at the top of the small box .

  woodchip 19:26 17 Mar 2007
  woodchip 19:32 17 Mar 2007

Found this but do not know if it works

OK – after an hour or so of faffing around :knock: , I think that I have found a possible solution :p . The problem seems to be something to do with Microsoft’s SP2 :dead: !
Here’s what worked for me (sorry for the Idiot’s Guide approach, but I used to :hotbounce hate it :hotbounce when I used forums and couldn’t understand what the technobabble meant!):

- Start > Run > type ‘regedit’ (without the speachmarks) > Enter
- Single-click on ‘My Computer’ > File > Export > save it to the Desktop (Always best to have a backup!!)
- Go to the following:
My Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDe vicePolicies
*There seems to be some spaces here in 'StorageDevicePolicies' in the text above, there shouldn't be, OK*
- Double click on the string ‘WriteProtect’ and change the ‘Value Data’ box to ‘0’
- Then: File > Export > save somewhere useful as something like ‘StorageDevicePolicies001.reg’
- You also need to do this for the strings in any folders called ‘ControlSet***’ (* = any Digit, i.e. 001, 002) – for example: Everything is the same, just change ‘CurrentControlSet’ to ‘ControlSet***’
My Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\StorageDevice Policies
*There seems to be some spaces here in 'StorageDevicePolicies' in the text above, there shouldn't be, OK*
- Save these to the same place as before as ‘StorageDevicePolicies00*’

The saves are in case it reverts at a later date, just double click (saying ‘yes’ to importing these to the registry) on all of the files and it will all work again!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique