USB Mass storage device problem

  Icky 06:57 12 Nov 2005

Any help for this one please?

Windows XP service pack 2.

For several months now I've been getting this message:

"There is no disk in the drive. Please insert a disk into drive."

I click on 'Cancel' each time and everthing starts OK.

I took the computer to a local computer repairer and he said it was a bug
in Windows and couldn't be fixed, so I've been putting up with it because
it was only a small inconvenience.

Today the computer takes much longer to boot up and in 'My Computer' the flash card
drives don't show. However, I no longer getting the message "There is no disk in the drive.
Please insert a disk into drive."

It did the same thing several days ago, I tried System Restore and that didn't
help. I did a registry clean up and it started working OK, but that hasn't worked this time.

If I go to hardware - device manager, the USB Mass storage device shows that it
is not working. I have right clicked on it and tried to update the drivers,
they seem OK. I have then right clicked on it , clicked on Uninstall and then
restarted the computer. It shows that a new USB device has been detected and
the computer starts up slowly. But the flash card drives still don't show.
If I click on USB Mass storage device properties it shows the message
“This device cannot start. (Code 10)”.

  Skyver 07:30 12 Nov 2005

Start in safe mode by pressing F8 repeatedly before the XP logo, select Safe Mode, go into Device Manager again, select View/Show Hidden Devices, delete your USB device (probably called something like USB Mass Storage Device), then all USB Root Hub entries, then any USB entries like Generic USB Hub, and reboot. If Windows still doesn't detect the device properly, do the same as before, but remove the USB Host Controller(s) too - the Root Hub/Storage Device entries must be deleted before you delete the controller entries though.

  Icky 14:23 12 Nov 2005

Thanks Skyver.

Sorry for the late reply -- been working!

I followed your instructions and all is OK now.

What a great forum this is.

  snr 22:07 15 Jan 2006

My mikom usb mass storage device takes info from the lap top but when plug into the desk top winxp2 ding dongs and the light flashes but there is nothing I can find to access the info. The drive is called UDISK2.0(F:)when in the lap top. There is an F drive already in the desk top.
Any ideas how I can get to the files in store?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Inside the iMac Pro - Apple's most powerful Mac yet

iMac Pro release date, UK price & specs

Comment nettoyer Windows et optimiser son PC gratuitement ?