USB Lexmark X73 won't work after XP reinstall

  dreuby 09:46 06 Oct 2004

I've been using all-in-one Lexmark X73 for a year, with no problems. I recently had to reinstall XP Home SP1 after a HDD failure. Now my printer won't work. I get "Cannot establish communications with the printer". What I've tried so far:
Different USB ports
New cable
Reinstall drivers
Used Lexmarks "registry cleaner" to completely remove from registry, and then a clean reinstall
Downloaded the driver (I had the latest, but I thought perhaps it might me a CD problem)
Installed XP SP2
Checked the BIOS for PnP settings

It works fine on my husbands PC. It works once or twice on mine, if the install completes OK. I've checked that "bi-directional" is checked. I've been through Lexmarks site, and contacted their support, but the solutions they gave haven't worked. It worked once after I'd found XP Add/Remove Windows components didn't have PnP checked, and ran the install dor that (though it didn't ask for my Win CD, so that part of Win must have been installed).

I can't really push Lexmark, as it was a reconditioned machine, so it really isn't their problem. It just seems odd that it should stop working after an XP reinstall. It doesn't support networking, so I can't use it from my husbands PC.

Before I start looking at ads for new printers :) can anyone suggest anything I haven't tried?


  ICF 09:55 06 Oct 2004

Have you followed the Lexmark installation procedure to the letter?(I know my Epson printer can be fussy of you don't follow it step by step)

Do you have any other usb peripherals running?

Is it a USB 2 printer?

Have you checked for any yellow triangles in Device manager? (especially Universal serial bus controllers)

  JonnyTub 10:11 06 Oct 2004

check the device manager, printers and faxes, right click on printer, select properties, when the new dialogue box comes up, click on the "ports" tab, put a tick in the (usually) USB0001 port and remove ticks from anything else.

  dreuby 10:17 06 Oct 2004

The printer worked OK on my USB 1.0 ports - we're thinking of installing USB 2.0 to see if that fixes it. I've got other USB devices, such as a thumb drive and my boradband connection, and they're OK.

We changed to broadband the same week I was reinstalling XP - I'm wondering if that's affected it. But my husband has the same setup, so I don't think it can be that.

Lexmark suggested that the USB hub needed a later driver, but I've checked that I have the latest - and the page for my hub (VIA) says that the driver won't affect the problem.

Device manager - I seem to have two entries for everything under USB. I have two root hub entries, and two host controller entries. I often have an "unknown device" entry, which I'm assuming is my printer. The driver info says it was installed by MS Publisher and the driver details are unknown. That entry is missing today, presumably as my printer is unplugged from my PC at the moment?

  ICF 10:29 06 Oct 2004

It sound like you have not installed the lexmark correctly.Follow the installation procedure to the letter.

  JonnyTub 10:35 06 Oct 2004

uninstall again (sigh, YOUR PROBABLY SICK BY NOW) damn caps lock, use this registry cleaner to (reg supreme 1.2) free trial from click here, delete all it finds, it creates a backup before it lets you delete so don't worry in that respect. Uninstall the printer from add remove programmes before you use the reg cleaner.

restart, install the lexmark software, only plug the printer in when the software asks you too, cancel any add new hardware wizards windows offers.

  ICF 10:37 06 Oct 2004

What motherboard have you got?
Is it a separate USB hub or on the motherboard?

  dreuby 11:29 11 Oct 2004

My broadband failed, and by the time it was back things were too hectic to get back here.

My husband installed a USB2 card, and the printer worked fine for two daya. Then the problem returned, on his machine as well as mine. So I guess it's the printer rather than XP. I follow the install instructions carefully, sometimes the install works, and sometimes it doesn't.

The problem seems to be that the printer is set at offline - when I choose Properties/Online, I then get "problems communicating with printer".

Thanks for all your advice.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Amazon Echo: What’s the best Alexa speaker?

Kano Computer Kit Complete review: A fun DIY 'laptop' that teaches kids to code

Best pro photo editors for Mac 2018

TV & streaming : comment regarder les Jeux olympiques d’hiver 2018 ?