USB hub problem

  [DELETED] 17:54 28 Jan 2006

Hi all, my brother-in-law has bought a 'newlink' usb hub which appears not to be working correctly on his laptop.

When originally plugged in, XP auto detected it, and the printer and camera that where attached were all detected. Everything appeared ok.

When he turned laptop off and went back later, after the bootup,neither the hub,printer or camera are detected.

But, if you unplug the hub and start from scratch, everthing is detected again.

This means everytime he wants to use the hub, printer, camera he has to shut down the laptop, unplug the hub and replug it in and its detected and everything linked to the hub is also detected.

I've just plugged hub into my laptop and it was detected straight away. Anything connected to the hub was also detected.

I turned off my laptop and rebooted and hub etc was detected.

So, why does the hub work on my laptop and not his? We are both using winXP sp2.

Many thanks for all help given,


  howard63 20:29 28 Jan 2006

some systems take a very long time to detect everything after a reboot are you sure that it is not detected not just taking its time. I have known a system take 15 minutes to detect everything.

  [DELETED] 17:56 29 Jan 2006

Hi howard63, I didnt realise a system could take that long to detect stuff. I've rang my brother-in-law and hhub in and leaving it for e has tried plugging the 30minutes and nothing has happened.

We have also tried uninstalling the usb drivers via device manager and rebooting the laptop.

having done this, the usb hub is detected straight away but if he reboots the hub is not detected.

So it seems that we still have the same problem.


  [DELETED] 17:56 29 Jan 2006


  spuds 18:32 29 Jan 2006

When you put printers,scanners on a hub system, there can be a power problem, and the device is perhaps showing as not connected at certain times.The same thing can apply to faulty cables.

  howard63 19:03 29 Jan 2006

I have seen other mentions of this and it appears that it is more common with unpowered hubs.

  woodchip 19:13 29 Jan 2006

If this does not have a mains adapter for the Hub, it is working at it's limit. Get a Mains Powered one

  [DELETED] 13:40 30 Jan 2006

Hi all, my brother-in-law has taken the hub and his laptop back to the shop where he bought the hub from and showed them what was happening.

he has left it with them too sort out.

many thanks for all help given,


I'll tick resolved and hopefully he will let me know what the shop do to solve this problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Amazon Prime Day 2018: Best Deals & Launches

The Huawei P20 Pro is the best phone for artists, designers and photographers

The best Amazon Prime Day Apple deals 2018

TV & Streaming : comment regarder la Supercoupe d’Espagne ?