USB HUB problem

  ANTHONY-268247 16:32 20 Sep 2004

I have just purchased a Lexmark X1100 all in one printer and am having difficulties in installing it.
Lexmark say that there is no fault with the equipment but the fault lies in my computer
An Evesham Evolution running XP home
This is because the device manager shows a yellow question mark against
they suggest that the driver for the hub is missing or damaged
I use my cadcam in the same USB socket and it works perfectly.
Onyone with any ideas as how to update the driver or am I on the wrong track.
I am not very well up in hub knowledge


  xania 16:41 20 Sep 2004

One of the major causes of problems is the order in which they are installed. Read the manual and install either the hardware or the software first as instructed.

Try deleting that Yellow exclamation marked item in Device Manager, then disconnect all USB devices and reboot the computer. Now, connect the printer - Windows should see it immediately and load all the approriate drivers - you may need your installation CD for this. Once this has settled, connect all your other devices one by one.

PS if you've only got 2 devices, you should be able to connect each directly into the back of your computer - at least to makes sure they are working. Once they arew ok, then install the hub if your need to; if you then get problems, you know what's caused them.

  livewire 17:24 20 Sep 2004

Interesting, I did not think USB hubs needed drivers. I would assume they are already presintalled with Windows XP.

When you double click the device in device manager, does it give you an error code? If so what is it?

  xania 12:51 21 Sep 2004

Windows does indeed have all the USB drivers, but it doesn't install then until you connect the first USB device. Now my understanding is that deleting the USB entries in device manager forces Windows to delete and then, on reboot, reinstall these drivers once the first device is attached. Now, of course, any damage to the drivers will be overcome by this thereby resolving many driver based problems

  JonnyTub 13:01 21 Sep 2004

usb hubs are notorious for throwing these kind of errors up. Printers like to hug usb ports all to themselves. Try removing the hub and plug directly into a usb port or one which is free. The reason being i believe is that the printer likes to be in cinstant communication with pc and the hub gets in the way of that if other devices are connected.

  ANTHONY-268247 19:11 22 Sep 2004

Thanks for responses
Still not having any success in installing printer.Tried uninstalling everything and starting again. The installation screens persitantly say can't communicate with the printer
and will not proceed further.Checked all cables which are of course new with printer.It goes dingdong when plugged in so assume cable is ok.Installation also says can't locate drivers on installation disc.Down loaded drivers from Lexmark webbsite will install but printer still will not work.Printer program says its printing but it's not

Lexmark say no problem with their printer as self tests ok. Must be a port problem as the installation program indicates a usb hub in the new devices entry in Device Manager.If it is deleted it returns on next installation attempt.

Evesham say uninstall the device select option to scan for new hardware and this will install correct drivers Port must be ok as other hardware works with it/.

Only other thing connected to USB connection is Broadband modem. Camera works perfectly when connected.

Could it be thet the new usb cable it faulty.

Dont know what to do next

Had a problem like this on an Epson cx3200(multi-function).But on 98se,it was the printer setting as it was printing to printer port.Changed it to read epusb1 portsolved the prob.Try Start-Control panel-printers-Right click printer-properties-Ports tab-USB virtual port to...Try this see if it works on XP

  spuds 19:51 22 Sep 2004

Some printers are like certain scanners, which can be a little funny via the USB supply.Try connecting the printer directly into the computer USB port, and see what happens. Another method would be to use a self-powered hub, if your's isn't already.

The next check is to re-install your drivers and printer, but make sure that this is a clean re-install.Remove the previous drivers and printer set-up and start from scratch.

  JonnyTub 00:46 23 Sep 2004

The problem is most likely as spuds suggests, althoough the response i would have made is that printers tend to be greedy with communictaion and like to be able to "see" the pc all the time. They can't do this through a usb hub with other periphials connected. If no other periphals are connected then assume that spuds and if so you need a self powered hub.

  JonnyTub 00:47 23 Sep 2004

hmm, i see i have already made that response :-)

  JonnyTub 00:49 23 Sep 2004

damn typing!! i meant to say "assume spuds is correct and if so...."

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Frida Kahlo's life, art and legacy explored in Google's new giant online collection and app

Best Android emulators for Mac

Comment importer des contacts d’un iPhone à un autre iPhone ?