USB host controller gone missing

  Septogenarian 11:56 29 Mar 2011

For some unknown reason all my USB ports have stopped working and when I look in device manager I find the reference to USB host controller missing, and all my USB devices have a yellow exclamation mark.Have tried scf / scannow as seen in replies to similar problems from other people but negative result. Have looked at websites that supposedly supply free replacement drivers but in the end they ask for payment. Have also tried the "Fix-it" service from Microsoft but seems a waste of time.
Would appreciate suggestions in simple terms. Thanks.

  gengiscant 12:36 29 Mar 2011

Go to your PC manufacture's or motherboard makers
website and download the drivers from there.
If you are unsure of the make of your motherboard use this click here it will tell you the make/model of your motherboard.

  Septogenarian 14:51 29 Mar 2011

Many thanks for that I will give it a try. Only problem is getting on to the internet with no USB ports , I am using an old spare PC to type this , different components obviously. Anyway I'll try to sort something out and report results. Thanks again.

  Septogenarian 15:55 29 Mar 2011

O.K. have downloaded and installed motherboard drivers and got the found new hardware and your hardware is ready for use , except that it isn't.
Now the problem seems to be with the Microsoft drivers , so have uninstalled and re-installed twice but still get the yellow exclamation marks despite the green ticks in the driver details box .
Have looked on my original XP installation disc but can't find USB drivers anywhere , went on a website that identified the drivers as faulty , but wanted payment to download replacements . mmm... what next?

  Septogenarian 20:18 29 Mar 2011

Am now getting error signal "unable to write svchost.exe , could this be the problem ?

  Septogenarian 15:40 30 Mar 2011

After trawling through Microsoft's tech. support pages I have found this was caused by me using a non certified , non compliant make of pocket flash drive , which shut down all usb ports.It is supposed to correct itself if withdrawn and rebooted but in my case it does not. Well at least now I know , but what use is Windows with no usb ports ? Good job I've still got an LPT port for my printer.

  Terry Brown 20:08 30 Mar 2011

From Run
type in services.msc
press enter

Check the universal plug & play devices are enabled.


  Septogenarian 12:10 31 Mar 2011

Thanks for that Terry , but I've tried most things.
According to Microsoft the make of flash drive I bought ( from a supermarket ) suffers from a problem called " babble " so Windows shuts all the usb ports as a safety measure. It's supposed to recover after reboot , but unfortunately mine didn't. C'est la vie .

  Terry Brown 19:41 31 Mar 2011

Just a thought.
Uninstall the software completly.

Open the Compabitity wizard (Easiest way -from help type in compatability and click on blue type)

Try loading the CD in a different setup- e.g win 2000 to see if it makes a difference


  Septogenarian 10:49 01 Apr 2011

Errrr.. I'm afraid you've lost me a bit there Terry , what software ? The flash drives these days don't come with any , and rely on XP to sort it out when first plugged in. The other makes of flash drives I have all did this and work fine in my laptop . No , I think it's just this particular flash drive with a documented problem ( cheap imports ) so I'll chuck it in the bin and if I need anything that requires usb access I'll use my laptop . Very much appreciate the suggestions . cheers .

  ronalddonald 14:37 01 Apr 2011

The software would the drivers who set up the computer you or someone else i.e. the company that made the computer. If someone else did they would have to have provided the drivers disk.

However i remember a laptop i had, xp home, there was a note saying that i should right click on the yellow question marks and follow the instructions, the xp home disc had the drivers.

so try inserting the disk and do a right click on the hardware section in my computer it might work

right click on my computer and click on hardware and scroll down usb host right click and see what it says

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Comment savoir si quelqu'un a bloqué votre numéro de téléphone ?