USB Gamepad?

  boon_intheuk 14:39 14 Apr 2003

Hello all, the Gamepad that is plugged into the game port on my sound card stopped working in so much as WinME could not detect in "game controllers", incase the Gamepad and/or Gameport are faulty I purchased a "Rockfire" Star Traveller Gamepad with a USB connection,
Some time ago I installed two USB ports into my PC by the way of a PCI card.
I have never tried to use them before. I believe you can plug USB connecting hardware into your PC without the usual stopping and starting of your PC so I plugged the Gamepad straight into one of the USB ports, but it does not seem to work.
It does not show up in "Game controllers" and if I try and "add" a gamepad to the list it still can't detect it.
Does anyone know if I am doing anything wrong?
Also is there anyway of checking the USB ports on my PC to see if they work ? (I don't have any other hardware with USB connectivity).
There was no software with the Gamepad.
Any help would as always be much appreciated.
Thanks, Boon.

SIS530 Mobo
AMD K6-2 400Mhz CPU
384 MBs PC100 SDRAM
Creative Savage 4 32MB graphics card (PCI)
TBS Montego Bay sound card (PCI)
200W power supply

  eccomputers 16:08 14 Apr 2003

you need to go into control panel, system and then click on hardware followed by device manager.
Scroll down to the universal serial bus section at the bottom and check that there are no exlamation marks on them indicating problems.
Also, check they are not listed as unknown devices. You should have had a disk for them.

  boon_intheuk 17:48 14 Apr 2003

Thank you, just to clarify, are you saying I should have had a disk with the USB ports PCI card?
Could I find the software for the card on the internet?
There do not seem to be any problems in the USB section of device manager.
Thanks, Boon.

  boon_intheuk 23:16 14 Apr 2003

Anyone else have any idea's?

  rev.bem 23:30 14 Apr 2003

You shouldn't need any software for your usb card

on your desktop right click on my computer then click on properties

click device manager and scroll down to universal serial bus controllers,click on the + next to that and look to see if there are any exclamation marks next to any of the items listed if not then your usb card should be working properly,if it is try shutting down your pc plugging your gamepad in and re booting to see if windows detects any new hardware

  boon_intheuk 00:19 15 Apr 2003

Appologies, but I have given out some wrong information in my posting.
I just had a look in my PC and I did not intall a USB port PCI card last year, in fact it is quite simply a back plate with two USB ports in it and the cable from the back of the ports plugs straight into the motherboard.
I don't know if this changes anything but I thought I had better mention it!

rev.bem, I did try your advice but with no joy.

Thanks, Boon.

  boon_intheuk 19:14 15 Apr 2003


  Colin 19:55 15 Apr 2003

If your USB ports are shown in Device Manager then the USB ports should be OK. When you plug the gamepad in, you should get a message saying "new hardware found" and the gamepad should install itself and just work. Did the gamepad come with a CD?

  eccomputers 20:41 15 Apr 2003

Go into the bios and make sure USB is enabled.
On some machines I have noticed that when they are disabled in the bios, windows still says they are there.

  eccomputers 20:44 15 Apr 2003

Another thought....

Does your motherboard have built in sound and a
game controller? If so, it may be conflicting with the one on your pci sound card. Again check the bios and disable it if this is the case.

I cant remember the motherboard, but about a year ago I had a customer that had this problem. The controller worked when plugged into the motherboard but not when plugged into the SB Live. This was the case also when the game port was disabled. I think it was a bios problem.

  boon_intheuk 22:39 16 Apr 2003

The gamepad did not come with a CD, it is supposed to be compatable with WinME, I tried it today on a PC at work running 2ooo pro and it just works with out having to do any installing.
I have also checked the BIOS settings and the USB controller is enabled.
So I am still a bit stumped.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Turn a photo into 16-bit pixel art

iMac Pro release date, UK price & specs

Football : comment regarder la Ligue 1 en direct ?