allanon 17:47 10 Feb 2010

I tried to install an Epson SX400 multi function printer. The same didn't work even though many many attempts were made. The installation process was followed to the letter but it still didn't work. Anyway I uninstalled the Epson software, and the folder from the Program list. When I tried to download pictures from my camera, windows did not recognise the fact that I had connected the camera. I tried a pen drive and a joypad with the same effect. However when I connected a USB light, it powered up, so there's power getting through. I have uninstalled the USB's and the roots in the device manager, and then let windows reinstall and this failed to fix the problem. There are no yellow icons in the device manager and when you open each USB they are all reported as working. Any ideas?. I think the issue must have been caused when I tried to install the printer, as I was using a joypad just before I tried to install the printer.

I have been on to Epson and they are absolutely useless!, no assistance merely loads of questions with no suggestions.

  tullie 18:38 10 Feb 2010

Have you tried to uninstall all your usb,reboot,and let windows reinstall them?

  allanon 18:40 10 Feb 2010

Yes, as stated above - I can't think of anything else to try apart from reinstalling windows. But if it's a hardware issue then this will not fix it. I've tried system restore as well

  peugeot man 23:11 10 Feb 2010

Strangely enough I have just spent the day trying to resolve a similar issue, USB ports working but printers not printing. (Win7 32bit)

System restore made no difference, neither did restoring from back up. Last resort was to reinstall windows.. Hey presto everything back to normal.

Luckily I learnt a valuable lesson a long time ago and have 3 hard drives.
1: Operating system only. 2:Programmes. 3:Storage

So unless you get any better advice it looks like a windows reinstall.

  DieSse 00:08 11 Feb 2010

I think this is a case to try a Registry Cleaner. I use Wise Registry Cleaner (free version), which sorted a somewhat similar issue on a clients system.

click here

Their Disk Cleaner is excellent too, I use it every day to get rid of unwanted files.

  Sapins 09:37 11 Feb 2010

Next time you need Epson support try their live online help. You can "talk" to a technician and it has always worked for me.



  Fruit Bat /\0/\ 16:37 11 Feb 2010

click here USB device view shows all drivers loaded and allows you to delete them.

  allanon 20:39 23 Feb 2010

Thanks for your input, and to answer your queries

tullie,I have already uninstalled the usb drivers and let windows reinstall them and this failed to fix the problem.

peugeot man, I have done two window reinstalls. A part restall from a protected partition of the hard drive and a total reinstall and no change. The USB's are still not working.

DieSse, tried the registry cleaner - and the system wouldn't load anymore. Had to do a system restore to get things back up and running.

Sapins- noted, but I will never buy a Epson ever again !. I put the USB probelms solely down to the Epson installer.

Fruit Bat/\0/\ noted but what will this do?. I've donwloaded and ran it but there's nothing obvious to me, which is wrong?

  allanon 09:51 23 Oct 2010

Just to close the thread down, in case anyone has the same problem,the problem was caused by a partial motherboard failure.

  Nontek 11:47 23 Oct 2010

In that case, you should give Epson an apology :-))

I am an Epson 'Fan' ... he he he!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?