USB driver problem

  susoki 22:35 02 Jun 2008

The usb ports on my IBM ThinkCentre were working fine but now I have an exclamation mark against one of the USB controllers in device manager. I have the latest BIOS and Intel chipset for my motherboard but when I try to upgrade the driver for the controller, I get msg saying 'cannot install this hardware ... access denied'. I have edited the registry usb entries to give highest permission to all users - this didn't work. I have upgraded to XP SP3 - no change. I did try uninstalling all the USB controllers and letting plug & play detect them but then they all had the exclamation mark and the only way to get 3 of them back was to go back to an earlier restore point. I can get a flash memory stick to work on the port but although it recognises my i-pod I get a msg saying that there was a problem installing the hardware. I would very much appreciate any other ideas before I go down the reinstall XP route.

  Fruit Bat /\0/\ 22:57 02 Jun 2008

boot into safe mode log on as administrator and give yourself administrator privileges in control center user accounts.

log back in as yourself and then try to reinstall or upgdate the drivers.

  susoki 16:47 03 Jun 2008

I am already a user with administrative privileges - is that what you mean? I have also logged on as the system administrator and tried to install without any luck. Appreciate your help with this.

  Fruit Bat /\0/\ 18:36 03 Jun 2008

TRy installing a different way:-

Use control panel Add new hardware and attempt to install the USB ports that way and see what happens.

  susoki 19:41 03 Jun 2008

The problem usb was listed with Code 28 - drivers not installed (which I already know about and am trying to resolve). Using the list of manufacturers hardware didn't show up any USB Controllers to select from and letting the system search for new hardware didn't pick up anything either. Can you think of anything else? I don't know why the system says there are no drivers installed when they obviously were originally.

  Fruit Bat /\0/\ 19:47 03 Jun 2008

Log into an account with Administrator privileges.
Click on Start, then Run. In the box type in Regedit and click OK.
In Regedit, right click on HKEY_LOCAL_MACHINE and choose Permissions.
In Permissions, give yourself Full Control. After that click the Advanced button. Check "Replace permission entries on all child objects with entries shown here that apply to child objects" and then click Apply. Click OK for any permissions that won't change. When this finishes, exit Regedit and try reinstalling the device drivers again.

  Fruit Bat /\0/\ 19:49 03 Jun 2008
  susoki 20:18 03 Jun 2008

Dear Fruit Bat - I'd hug you if you were here. Changing the HKEY_LOCAL_MACHINE permissions as suggested has worked and I now have no more exclamation marks in my device settings and, most importantly, I-tunes recognises my i-pod - thank you so much.

  Fruit Bat /\0/\ 21:27 03 Jun 2008

Your welcome.
glad its fixed.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique