USB Dongle problem

  puffer 2 13:35 15 Sep 2008

I have a Dongle used for Digital Amateur Radio which can talk to repeaters world wide by plugging it into a USB port. A headset is plugged into another USB port and the device is started up using a "Jar" file. The latest JavaScript is loaded, and at one stage I thought that I had it working. On attempting to open the device, an error message comes back "Cannot open device local host:20002. There is no fault on the device because it works on a laptop, but there is insufficient memory to actually operate it. The problems appeared to start when I installed Kaspersky internet security, but this may be just a co-incidence. I've turned this programme Off completely, it makes no difference. It assigns itself to an "unused port", COM 6 in my case. If I try using "hyperterminal" to open this port, it claims that there is another Telephony device using it. If I use TcpView, then nothing else is using COM 6 or 20002 at all. Both Kaspersky and DVDongle software people have tried to assist, each party convinced that their bit works OK, it must be my Windows SP2 system! Can anyone throw any light on this problem please? Peter

  woodchip 13:44 15 Sep 2008

Check windows Firewall is stopping you

  woodchip 13:45 15 Sep 2008

Check windows Firewall is not stopping you

  puffer 2 14:08 15 Sep 2008

Windows Firewall definitely turned off, also paused protection on Kaspersky, still cannot connect. You know when it fires up because the Dongle parameters all come up on the DVTool page.

  woodchip 19:01 15 Sep 2008

Do yo have to input anything into Dongle Software like a USB Adapter for Wireless setup?

  puffer 2 19:48 15 Sep 2008

No, the box containing the electronics is simply plugged into a convenient USB socket. A Logitec, or similar, USB headset occupies another USB socket and self installs. You have to have Java installed and unzip a small initiating programme as per the DVDongle website. You then double click on the "Jar" icon and the Dongle's serial number, firmware issue etc appear in the heading. You can then select a variety of repeaters all over the world by internet to the selected site and couple up with radio links even from Australia, presumably via port 20002. In my case it works on the laptop which requires more RAM and perhaps more CPU power in order to decode the data coming in. Sadly on the Mesh desktop, it is now refusing to open port 20002, or something is stopping it. I am sure that it worked originally for a couple of nights, but I didn't have a headset at that time so could not transmit. These changes all seemed to come about when Norton was thrown out and Kaspersky was installed. However, switching the whole firewall off makes absolutely no difference! I haven't used the Windows firewall for ages, but have doubled checked, and that is definitely still "Off". I've just tried a programme called TCPview which will access any named port from the test end. I tried 20002 and it opened in 5.09 seconds! I'm completely baffled.

Cheers, Peter

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?