USB Devise Unrecognised - Epson CX6400

  shrewsbury1 16:28 03 Sep 2006

I have been using an Epson CX6400 MFP for some time on my PC under XP Home with no problems.
When I went to print out some emails nothing happened and I found that the printer although on was not being recognised by the PC. Unplugging and replugging the USB produced a message about an unrecognised USB device with the Device Manager showing Unknown Device.

All attempts to get the PC and the Printer to communicate have failed. I have uninstalled all software, drivers etc, gone back as early as I can with System Restore without success - Windows Defender appears to set up that many restore points that earlier useful ones are lost! I tried to use the original Windows disc but stopped when it advised me that the system had much later version (SP2 etc)

The printer is recognised perfectly well by my wifes laptop and functions OK, so it appears to be the PC rather than the printer.

What do I try now?

  recap 16:36 03 Sep 2006

When reinstalling the software shrewsbury1, did you also update the driver for the printer?

If you click here you can get the latest driver.

  shrewsbury1 17:02 03 Sep 2006

Currently there is nothing on the PC relating to the printer. I have the disc for the printer but have not tried to reinstall software etc as I cannot get the machine to recognise the printer when plugging in. The PC will not find any drivers on the disc as it is looking for something for "Unknown Device" not a printer.

  citadel 17:11 03 Sep 2006

on my printer you have to install the printer software first before you plug the printer connecter into the printer. you only connect when the wizard tells you to plug it in.

  shrewsbury1 18:01 03 Sep 2006

Have tried again setting up s/w etc. Step 2 says make sure printer is connected then turn on. This gives rise to message "USB device not recognized. One of devices has malfunctioned and Windows does not recognize it. For assistance click" which shows location of device on USB Root Hub as Unknown Device.

Setting up shows it has not found printer and askes if you want to configure it mannually - sets it as LP1.

At end of setting up, restart PC and using Printer Properties reset it as a USB port. Still shows Unknow device under Device Manager and any attempt to use printer, gives message "Printer Is Not Ready to Print".

  woodchip 18:13 03 Sep 2006

First Unplug the Printere, Go to Device Manager Uninstall any yellow icons, then starting from bottom of the USB list, uninstall each and all USB. then restart Computer and let it do it's thing. Then plug the printer in

  shrewsbury1 20:38 03 Sep 2006

No yellow icons; uninstalled all USB ( a little problem as lost my wireless K/b and mouse!). Restarted and after establishing KB and mouse, no joy with printer - Unrecognised device, still showing as Unknown device in Device Manager

  woodchip 20:47 03 Sep 2006

Have you tried Removing Printer from Add Remove in Control Panel Then do a Search for Epson ans Delete all it finds. Hope you do not have Other Epson or you will Have to reload all of them. Unplug printer before you restart Computer. Then after Restart Load Software and Drivers then plug printer in, Some of Epson Drivers look for printer when loading if it does switch the printer on after pluging in

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?