USB device not recognized Again for printer cable

  ttmiller01 03:35 12 Nov 2008

A few months ago I had this same problem with my Konica Minolta printer's usb cable. Suddenly after years of functioning properly, i started to get this message when i connected my computer to the printer "USB device not recognized." i uninstalled the printer several times, nothing worked until i replaced the usb cable and now its happening again. I dont think its the cable, its a fairly new cable. All other usb devices work in all the ports. What could be causing this problem Please help.
thanks in advance,

  €dstowe 06:48 12 Nov 2008

All sorts of dire things can happen if you unplug a USB device while it is doing something. It is usually drives that are worst affected but I have known a printer never to work again after its plug was accidentally knocked out whilst it was mid-print.

There were loads of fanfares when USB was introduced about it hot-plugging capability. This may be so but it was not mentioned that it didn't include hot-unplugging.

  ttmiller01 16:22 12 Nov 2008

thanks for your response. I think the problem happens when I disconnect my computer, while the printer is in sleep/power save mode and then try to reconnect.

  Fruit Bat /\0/\ 16:26 12 Nov 2008

Use Drive clean up to remove USB device drive info from the registry
click here

then reboot and let XP find and reinstall the necesary driver.

  ttmiller01 04:00 13 Nov 2008

thanks, but i did that as well...and to no avail. I plugged in my original usb cable (the one i first replaced) and the connection worked for about 1 minute, long enough to print a test page. Then it went back to being unrecognized. I also tried two new cables including (a parallel port/usb) and neither worked. I hope i dont have to get a new printer.

  Simsy 07:33 13 Nov 2008

a while ago, and it turned out to be a USB port problem. Uninstalling and reinstalling the driver did work for me... Then the problem recurred.

The port was on a pci USB card. It turned out that this had gone faulty, and replacing this cured it. If the port concerned in your case is on a pci card perhaps you have a similar problem. (They are only a few pounds)

Is the problem with all ports, i.e direct motherboard ports, via a card and/or via a hub?



  ttmiller01 14:38 17 Nov 2008

simsy, thanks for your reply. I'm a layperson when it comes to knowledge of computer hardware. I have no idea what the answer to your question is. What's a pci usb? what are motherboard ports?

I hooked up a inkjet printer with the same usb cable and it worked. So at least now i know its definitely a problem with the printer. The konica minolta tech person over the phone said it might be an error with the printer's communication system. Is this something a non-technical person can fix?


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique