USB Device not recognised

  Emsie 12:33 01 Jan 2009

When the "USB Device not recognised" window opened this morning, we followed all the instructions to remedy this. We only have 3 things attached: the cordless mouse+keyboard, the printer, and the camera.
Device Manager reports no problems. But in the USB section, the fourth one down says: unknown device.
We've unplugged and re-plugged each cable; and then we've tried each in a different port. We've checked the drivers are up-to-date. We've tried re-starting the pc. We've run malware and virus scans. We've run Ccleaner.
But the pesky message STILL keeps popping up!
Please - does anyone know how we can sort this problem? Thanks!

  Sea Urchin 12:40 01 Jan 2009

Worth a try

click here

  ronalddonald 16:37 01 Jan 2009

what version of winodws are you using, if its xp may be if you reinstall the drivers disc and see if it remedy's the problem.

Im presuming the device use to work on usb connection b4 this morning. also right click on my computer and go to properties and hardware device manager and look at the usb connections and enable them but try reinstalling the drivers first.

  Fruit Bat /\0/\ 17:21 01 Jan 2009

In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  chub_tor 18:22 01 Jan 2009

Do you have a built in card reader that is attached to an internal USB port on a header on your motherboard. If so that could be the "USB Device not recognised" Then follow Fruit Bat /\0/\'s advice

  tullie 18:26 01 Jan 2009

Would there be a drivers disk,i thought these drivers are part of windows,as mine have allways been.

  Emsie 10:37 02 Jan 2009

Thanks very very much for all your support!
We downloaded RegCure, (thanks, Sea Urchin) and it flagged up all sorts of problems, but then said the free version couldn't sort them; we'd have to buy the full version. So before doing that, we thought about ronalddonald's and Fruit Bat's suggestions. We uninstalled the USB device that was shown as problematic in Device Manager, re-booted, and let it reinstall. It still said it was an unknown device while the desktop was loading, but the little window then vanished and now it's quiet.... fingers crossed that's done the trick!
In case this helps anyone else: we're running XP and don't have a built-in card-reader, and the errant USB slot said it didn't have a driver, so we couldn't update it.
I'll report back in a few days to say if the problem's gone. Thanks to all of you, so much.

  Sea Urchin 21:01 02 Jan 2009

I didn't knowingly recommend RegCure - although I now see it shown on that link as a download. I was actually suggesting you read the article, where the author explained how he overcame your problem. Sorry I didn't make it clear - in fact I wouldn't recommend RegCure for the very reason that you discovered, plus the fact that it can sometimes cause more problems than it solves IMO.

  Emsie 10:52 06 Jan 2009

Sea Urchin - many thanks, plus apologies! We revisited your link and read lower down the page, and followed the advice. We just switched off the pc and unplugged it, and then switched it all on again after a while. So far, so good! (And we've uninstalled RegCure.)
The previous uninstalling-of-USB remedy looked very promising at first, but didn't last, alas. Again, we'll see what happens over the next few days and will report back! Thank you so much for your help.

  Sea Urchin 11:14 06 Jan 2009

Will look forward to hearing in the next few days whether it seems to have worked

  LANDCRUISER 23:25 06 Jan 2009

i have the same problem so i will bump this thread so i can follow your progress

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough, a non-profit against sexual misconduct

What to ask Siri on the HomePod

Meilleurs VPN (2018)