USB Controller Problems After An Crash

  DiabloAwesome 09:55 02 Feb 2019

My computer recently crashed while I was playing Yakuza 0 with a USB controller. A reset was required, but when the PC returned no gamepad command is recognized by the computer.

First I thought the controler was faulty, but I tested it on another PC and the controler works fine. Afterwards I thought it might be the USB port, but on testing it showed no defects. Finally the drives, which I uninstalled and reinstalled. But no results.

Now I've noticed that the in "Devices and Printers" clearly shows that the controler is detected by Windows. But when you see in "Set Up USB Game Controllers" nothing appears.

click here image of what I'm talking about. I have no idea how to fix this. I would try to restore the system, but it does not have a restore point that precedes the error. I'm suspecting that some drive that I might've missed is causing this problem or the configuration tool has corrupted in some way ... But I'm not sure.

An

  Fruit Bat /\0/\ 10:18 02 Feb 2019

As it is only showing up as a generic joystick you need to load the driers for it.

  DiabloAwesome 11:27 02 Feb 2019

I tried to mess with the drivers for hours. And it wasn't what it started, all the problems start immediately after the crash, the driver messing came later

  Fruit Bat /\0/\ 13:19 02 Feb 2019

Unplug it.

Try using USBdeview (free) to uninstall it, then reconnect and reinstall the drivers.

USBdeview will remove driver info from the registry that may be causing a conflict.

  DiabloAwesome 13:55 02 Feb 2019

Tried that, still nothing. The more time pass, the more I'm starting to think it's Windows fault.

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Xiaomi Mi 9 Release Date, Price & Spec Rumours

Illustrator Owen Davey on how he's created a successful series of animal-themed children's picture…

MacBook Pro 2019 release date, 16in MacBook Pro news and rumours

Xiaomi Mi 9 : date de sortie, prix et autres rumeurs