USB 2.0 hub not recognised in XPH SP2

  The queen of sheba 14:51 10 Feb 2006

I've found similar but not exactly the same postings so apologies if repeating.
D-link USB 2.0 hub . Works perfectly in any other PC. Any other USB device works fine. If I connect the D-Link USB2 4 port AC powered hub into a customer PC we get Device not Recognised pop up + same in Device Manager. Connect same hub to different PC works fine. Connect replacement hub to customer PC , same error. Was working perfectly for 3 months but not now. The problem is not with the hub + all other devices , printers , camera , card reader , mouse , adsl modem all work fine. Searched the web and lots of similar problems but no fixes. Some reference to timing and hibernation but of no help.

Anyone had this problem and fixed it. The PC was brand new 3 months ago and has no other problems.

Any suggestions.

  Fruit Bat /\0/\ 19:47 10 Feb 2006

Hub not being recognised by PC!

Does this happen if you plug it into any port on thr PC?

Device not recognised can be caused by defective drivers for the USB port.

Uninstall ALL the USb root hubs in device manager, reboot the PC and let XP find and install new hard ware.

  The queen of sheba 10:48 11 Feb 2006

We'll try that but yes , it doesn't make any difference which USB port the hub is plugged into , it doesn't work. I've even plugged it into another identical hub on another PC and it works fine. Any single piece of kit plugged into any single USB port on the problem PC also works perfectly. Therefore the individual USB controller must be fine , the actual ports work but it just doesn't like hubs.Although it was working from new for three months without any problems.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Brilliant (and Weird) World Cup 2018 Art and Design Projects

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?