USB 2 external HD not recognised

  whitehall 22:11 17 Feb 2005

I have recently installed a PCI USB2 card and hub.
I have Win XP (SP2) installed, my external HD works fine if plugged up to one of the USB1 ports although I get a message telling me that "The USB Mass Storage Device is a HI-SPEED USB device and will function at reduced speed when plugged into a non HI-SPEED port. The hubs shown in bold type have ports that can support HI-SPEED USB devices, disconnect the USB Mass Storage Device from its current port and then connect it to one of the ports on a hub shown in blod type.
If I do this I get a message: H:\ is not accessible, The request could not be performed because of an I/O device error.
When I go to device manager, there is nothing showing a problem and my USB device can be seen under Disk Drives as a WDC-WD400bb.... USB Device, there are also no conflicts under USB Controllers.
If I use my external HD, ignoring the HI-SPEED message as plugged into a USB1 port, ll fuctions fine.
I have looked at the device driver for the USB external HD and it tells me that drivers do not need to be loaded for WinXP, only for W98.
Any help much appreciated.

  Fruit Bat /\0/\ 22:26 17 Feb 2005

Uninstall USB2 root hub


click here

click here

  whitehall 22:42 17 Feb 2005

I have uninstalled and re-installed USB2 root hub to no avail, have also had a look at the links kindly posted, tired to download latest drivers for ALI PCI to USB open host controller but each time I click the link I get a timed out error message.

  cagey 23:13 17 Feb 2005

Got the same problem as whitehall, tried the above with same results. Any help please?

  cagey 11:35 19 Feb 2005

Can anyone help please?

  Diemmess 12:37 19 Feb 2005

Quite often the "message" doesn't seem to get through if the USB device is already plugged in when the software is first loaded..... In fact hot plugging seems a must for first connection of some devices.

So this may seem a daft suggestion but if you are really stuck then I suggest unplug the external HD, go through the motions of uninstalling the appropriate drivers and even reboot. Reinstall and only THEN..... plug the USB2 HD in once more.

  whitehall 16:01 19 Feb 2005

Umm, unfortunately, I have been there and done that.
When hot plugging, I am told that my device is ready for use, but is not listed under "My computer" or "windows explorer". No drive letter seems to be assigned to the drive.
If I then reboot when the machine has told me that it has found new hardware and that it is ready for use, my machine refuses to boot into the O/S.

  cagey 16:13 19 Feb 2005

Sorry, but this is not realy my thread, but if it cures a problem then it may help "whitehall".
I'll give it a try and let you know the outcome.

  howard60 16:46 19 Feb 2005

have you tried loading the usb2 drivers from your mobo cd or downloading the drivers from the mobo makers site?

  whitehall 20:04 20 Feb 2005

Have loaded the USB2 drivers from the PCI USB2 card and hub, instructions were to load drivers first, then install PCI card, which I did. The card was then recognised and drivers automatically found and all is reported as in working order.
My USB2 external HD does not have drivers for WXP, only W98 and in the info .txt file on the supplied CD, it says that drivers are not required for WXP, just plug up to a USB2 port and all will automatically work.
Just in case all didn't load in the correct order, I have even formstted my HD and started from scratch, again to no avail.

  cagey 10:51 24 Feb 2005

I found a site and downloaded updated drivers for Ali USB2 PCI card. But when I tried to install it I get a message "WinXP SP1 has default driver so do not need Ali EHCI driver" and will not let me proceed any further. I thought this might be the solution to whitehall's problem. Anybody got ideas as to how to load this driver.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?