USB 2 crashes computer. USB 1 all fine

  User-B0F204E4-9DA7-4ED8-996ABD17346F963C 10:36 20 Jan 2010

I have recently re-formatted my hard drive and re-installed Windows XP on my laptop. BIOS updated to the latest and all Windows updates installed.

Ever since installing Windows this time my computer freezes as soon as I plug a USB 2.0 device in to the built in ports. I also have a PCMCIA USB card and they work fine in there.

This happens to ALL USB 2 devices - including hubs and a wireless stick. USB v1 flash drives, printers etc are all recognised and installed with no problems.

This happens in Safe Mode as well, and if the 2.0 device in plugged in during bootup the computer hangs.

I have tried uninstalling and reinstalling all the USB ports in device manager and making sure latest drivers etc installed.

USB ports are all SiS 7001. Computer is Amilo A1630 with 1.05 BIOS (which is very scant in its options - no power management or USB options).

Any ideas gratefully received!

  [email protected] 11:35 20 Jan 2010

worth a look, see if theres anything on these links that may help.
click here

click here

Thanks Raven. The PCMCIA card is working fine, it's the internal USB ports that don't like USB2.

Does the Cardbus controller have anything to do with USB ports?



  keef66 13:19 20 Jan 2010

Have you also reinstalled the original chipset drivers etc?

Have a look in Device Manager see if there's any yellow exclamation marks next to anything, and whether you have 'enhanced controller' listed under usb.

I have reinstalled the SiS drivers. There is an enhanced contoller and the status says it's working properly.

The only device with an exclamation mark is "Base System Driver" (but that lost its driver months ago and it's never apparently affected anything). No Googling comes up with a driver for that...

Thanks for suggestions - even if I've already tried them I'm grateful.

I have downloaded and installed the SiS AGP drivers and the PCMCIA drivers. I can't find a SiS 7001 updated driver anywhere.

Still have same problem.

Incidentally, my USB 2.0 drive works fine as a boot device, so it's clearly a Windows problem not BIOS or hardware.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Explore Milton Glaser's iconic poster designs from the 1960s to present, including Bob Dylan, I…

What to expect at Apple's 27 March education event

Idées cadeaux pour geeks et tech addicts