Unknown Device in device manager.

  birdface 10:47 29 Apr 2012

I have this unknown device in device manager,It has no file or driver,I have tried everything to get rid of it including deleting it but on reboot it appears again.

Tried removing it and running C Cleaner but it keeps returning on reboot.

Tried Intel and nothing there to help.

This is the only thing I can find about it.Unknown device on Intel(R) ICH7 Family LPC Interface Controller - 27B8

I don't think there is anything that will fix it.Just wanted to know if there was a way to remove it from the Device manager.

I can disable it but sometimes it appears enabled again.

The problem is I think that the computer keeps looking for updates for it and I have noticed a slight slow down on opening pages in PCA.

Googled for it and so far found no fix for it.

  KRONOS the First 11:12 29 Apr 2012

Was this not solved here? I may be wrong as I must admit I lost track of what the problem actually was. Earlier post.

  birdface 11:47 29 Apr 2012

Yes it was what I was thinking was stopping my Internet Connection but found out it was nothing to do with that.

I still have the Unknown device which I cannot remove,Intel does not give a fix for it and Foxconn is a bit of a waste of time with no fix either.

Basically all I want to know is there a way of removing it from device manager or will it always be there.

There is no File for it and there is no driver for it so not sure what to do next.

There have been one or two others with the exact same problem on Google.One resolved it by flashing the Bios But trying to pin down the actual Bios update that I need is a problem for me.

All I can find is Bios vendor Phoenix Technologies Ltd and version 6.00 PG

  KRONOS the First 12:21 29 Apr 2012

And your motherboard is? SIW will tell you all you need to know.

  birdface 12:23 29 Apr 2012

Had a look in the Bios and it gives this.

Bios ID G31M04-GA,F1.P.12 so will see what I can find with that.

  birdface 16:42 29 Apr 2012

Motherboard is.

Foxconn G31MX Series (Socket 775):

Operating System MS Windows 7 Home Premium 32-bit SP1CPU Intel Pentium E5300 @ 2.60GHz: 38 °CWolfdale 45nm TechnologyRAM 4.00 GB Dual-Channel DDR2 @ 400MHz (6-6-6-18)Motherboard Foxconn G31MX Series (Socket 775): 40 °CGraphics SyncMaster ([email protected])Intel(R) G33/G31 Express Chipset FamilyHard Drives 488GB Hitachi Hitachi HDT721050SLA360 ATA Device (SATA): 28 °COptical Drives TSSTcorp CDDVDW SH-S223B ATA DeviceAudio Realtek High Definition Audio

Thought that I would add the rest just in case.

Cant find any updates for it but I am not that confident I am looking in the correct places.

It says Bios vendor,Phoenix Technologies Ltd. Bios version 6.00 PG.

Not even sure that flashing the Bios or even updating it would help but worth a try I suppose.

  rdave13 17:07 29 Apr 2012

This any help for drivers?

  KRONOS the First 17:19 29 Apr 2012

What are you using to get the details? Try this HWinfo. run this then move the system summary box out of the way,click on motherboard on the left hand side and that will tell you all you need to know including the BIOS.

I must add that with modern motherboards,flashing the BIOS is a walk in the park but unfortunately yours is not modern,and is certainly not an easy process and one that if you are not completely confident of getting it right, then I would leave well alone.

  lotvic 17:45 29 Apr 2012

Unknown device on Intel(R) ICH7 Family LPC Interface Controller - 27B8

After googling the above, it seems to be: "The LPC interface is the replacement bus for the old ISA bus, and is used to communicate to low bandwidth legacy devices like Serial, InfraRed (IR), and parallel ports, Floppy Disk Controller, keyboard, mouse."

One suggestion I found was to disable IR in the BIOS (if that option is available on yours) Advanced> Peripheral Configuration > IR > Disable

  birdface 17:58 29 Apr 2012


Yes been there but not sure if anything there that I need are they all for my board and for W/7.

Not wanting to download anything that is going to make it worse.


I have been using SIW and heard that Speccy was quite good so trying that as well.

I tend to agree with you about, if you are not completely confident of getting it right, then I would leave well alone.

I was thinking the same thing my self.I just hate little problems that I can't fix so maybe best leaving this as it is and to save me from making it worse.

The Bios is stated to be from Phoenix technologies.I have looked there as well without much luck.

I keep getting sidetracked it is probably nothing to do with the Bios so I am going to close this thread and hope that I can solve it in the future.

Thanks both for your help it has been appreciated.

  birdface 18:02 29 Apr 2012


No tried the Bios and there was no sign of it.I will have a look and see if it is in Services but I doubt it.

That was the 2nd fix that I seen the other was Flashing the Bios and none of them worked for some of the others with the same problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Amazon Echo: What’s the best Alexa speaker?

Kano Computer Kit Complete review: A fun DIY 'laptop' that teaches kids to code

Best pro photo editors for Mac 2018

TV & streaming : comment regarder les Jeux olympiques d’hiver 2018 ?