Unhandled Exception in Managed Code Snap-in?

  Graphicool1 10:42 29 Nov 2011

Started in 'Safe Mode'

Event Viewer:

MMC has detected an error in a snap-in and will unload it.

'report this error and then shut down MMC'


'Unload the snap-in and continue running.'

(I chose the latter)

Unhandled Exception in Managed Code Snap-in


The network address is invalid. (Exception from HRESULT: 0x800706AB)

Exception Type:


What do I do now?

  johndrew 14:10 29 Nov 2011

Have you seen the MS offerings here and here on this subject? They may help.

  Graphicool1 15:18 29 Nov 2011


No I hadn't seen these, but (your first link) an in place system restore doesn't fill me with encouragement. As yet I haven't tried but I'm thinking of perhaps giving sfc /scannow a go. Before doing anything too drastic.

Although, the reason I posted this is because this was the last error on the list that I found after seeing the BSOD and having to start in 'Safe Mode'. However I'm not now thinking that this was the culprit. I'm thinking that it might have been the VMware Player that caused the BSOD. While in Safe Mode I uninstalled that and after rebooting everything has now started up normally.

  johndrew 15:24 29 Nov 2011

You sound as if you have found the culprit. It could easily be that Windows is unhappy with a virtual process running at startup. Have you tried starting it after Windows has fully booted?

  johndrew 15:29 29 Nov 2011

Meant to add. Using 'Startup' in MSConfig deselect (untick) VMware Player and save. You can start it from All Programs or create a shortcut on the Toolbar.

  Graphicool1 16:17 29 Nov 2011


Since installing VMware and running it on an external drive I installed WinXP, so I could run software not compatible with Windows 7. However it never performed very well, there were many hiccups. Then I discovered that although it was compatible with my PC, it wasn't compatible with my flavour of OS which is 'Home Premium 32bit'.

"Have you tried starting it after Windows has fully booted?"

That is how I've always used it. As it's on (was on) an external, non booting drive. Windows had to be up and running before I could enter the other drive. It was, to the best of my knowledge never in Windows 7 Start-up. Although after seeing your last post I had a look, just in case it was there and it isn't.

I won't be reinstalling it again, anytime soon.

  johndrew 14:21 30 Nov 2011

I see your problem. W7 Pro is the OS that would suit you, but it would be a heavy cost now you have purchased Premium - unless an upgrade is within budget?

  Graphicool1 14:30 01 Dec 2011


"unless an upgrade is within budget?"

I'm afraid all my 'disposable cash' as they like to call it, is tied up at the moment. I'm buying a 3 bed bungalow on a tight budget. It was on at £145,000 we said £130,000 final offer and they accepted! Although I don't think that our shrewd bargaining had anything to do with it. It was more likely because, in the month that it's been on sale, we were the only ones to view it. I think that the reason there had been no interest was possibly because there had been a fire at the premises and someone had died in it.

However, the way we look at it is we've all got to go sometime, how and where isn't often our choice. Still the insurance company have done a good job redecorating. New bathroom, new kitchen, new stainless steel oven, hob, extractor and fridge. With no chain they estimate we'll be moving within 4 - 6 weeks.

  johndrew 15:13 01 Dec 2011

In this climate I understand exactly where you are. We first bought in the early 1970s and when we moved in 1976 the property value had hardly moved. I have a feeling we are going to see it all over again - and not for the first time.

What I really hope is that we don't get into what happened in the late 1970s/early 1980s when inflation rocketed; that really hurt.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

How Pentagram and other design agencies aim to double the number of creative female leaders

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?