UnableTo Load Printer Drvr

  DWANE PYPE 16:41 22 May 2008

I have been trying to install the driver for my Canon iP4500, but try as I might, have come to the conclusion that, some thing is stopping it.

The question is Can anybody tell me why, or what is it thats doing it???.

Any suggestions will be VERY much appreciated.


  Fruit Bat /\0/\ 16:42 22 May 2008

Why have you come to that conclusion?

  DWANE PYPE 17:44 22 May 2008

Good question!. if you looked at my earlier thread you will have read I've just about tried every thing to get it to work, but no joy, so I was thinking along the lines that something is stopping it. (i.e."conflicting")

But I think your going to tell me I'm barking up the wrong tree.

So if you can put me wise, I would be very very grateful, as I've been trying all week to do it.


  MAT ALAN 19:26 22 May 2008

click here

have you tried repairing the windows installer...

  DWANE PYPE 20:00 22 May 2008

thank you all for your responses.

Will try that very shortly,In fact as soon as I've finished my reply.

I,ve uninstalled the drv with Revo Uninstaller,that cleared the registry.
There has never been an entry in the Printers& Fax,have tried add a printer (it shows up in there)but when I press finish at the end, a window pops up and says that the driver is not installed.

When I try it with the Wizard, when that finish's,it says error, cannot find the appropiate file, but doesn't say which one??.

All files are on the C drv but some how there not being read.

Many thanks


  skidzy 20:21 22 May 2008

Maybe you have tried this Dwane;

Download this driver to your desktop click here=

First run ccleaner if you have already uninstalled the current canon software click here


Plug in the printer,and when asked for the driver...point the request to the downloaded driver on your desktop...see how this goes if not tried already.

I take you have enabled the print spooler service ?

Start / run and type


And enter,now scroll through to the print spooler service and enable this if disabled.

  DWANE PYPE 21:27 22 May 2008

Its the windows wizard that can't.
went into the that and tried the command route,
I had to put this in the command box,

msiexe /ipackage(ip4500)/ilogfile(and I don't know what to put here).txt
Didn't put anything in the log file,pressed enter
and this window came up.

"This install package could not be opened, verify that the package exists, and that you can access it, or contact the application vendor to verify that this is a valid widows installer."

Got that,and the one off the USA site'

Ran cCleaner,

Will try the reboot:(have tried that many ways I could possibly done it but will try it).

Spooler is working, as I tried to install the drv in safe mode but that said it wasn't working, but I checked it in Services after rebooting, and it's up and running.

Thanks again,


  Stuartli 09:56 23 May 2008

I presume this is a USB printer - if so, then the drivers and software will almost certainly need to be installed first and the printer connected when advised.

  DWANE PYPE 17:43 23 May 2008

What happens is this, when I use the CD, and I get to the bit were you to have plug in the cable and switch on, when I do that, the detected new hardware little widow appears, then the wizard pops up saying it can't find the relevant file, but never says which *** file, and on the bottom it says "Finish", click that it goes and I carry on.
I tried a restore to the day before this epic started, it went through the motions, but at the end it said it could not restore to that time.

It is a USB connection, and have done it as per the CD.
The thing I can't under stand is that all files are on the HD, In the Canon folder in Programmes,
and in the Spool folder in System 32,so why are they not being found, or is that the actual drivers are not in them???. I say this because when I try to put it on through the add a printer route, it says the printer is there, but when I get to the end of that, click the "Finish" button,up pops a window that says unable to complete installation, the Drivers cannot be found.

"So what can you do when your boots let in."

Please keep the suggestions coming, (I'm Desperate,well I've had it a week now and it has only worked on the wifes PC, "no problem").

Thanks again,


  woodchip 18:18 23 May 2008

try copy the cd to desktop, restart computer in safe mode, then run setup from the copy on the desktop

  DWANE PYPE 18:43 23 May 2008

Thanks for that, will give it a go later.(teatime)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique