Unable to write to floppy disks with windows 7

  fishmad pete 07:26 22 Mar 2010

This is a strange one.
I have just built a PC using a giga-byte GA-MA790XT-ud4p motherboard.
I downloaded an update for the bios and tried to copy the file onto a floppy disk. But although windows first of all reported that the file had been copied, it was not on the disk. Removing and replacing the disk into the computer windows7 reported the disk as empty although in properties the disk showed that it had a used portion. Subsequent tries resulted in getting a write error. Placing said disk into another computer (XP) resulted in a write error. Files placed onto a floppy in the "good" computer were read by the windows7 computer with no problem, but as soon as I tried to add more files using the windows7 computer, the floppy was corrupted.

My research so far points towards an incompatibility between windows7 and AMD chipsets but I can't find a solution.

I know that floppies are old and obsolete and I don't realy want this thread to result into a debate of usb pen drives versus floppy etc. All I want to know has anyone come across this problem and found a solution?

  fishmad pete 07:51 22 Mar 2010

The version of windows I am using is Windows 7 home premium. The floppy drive was working prior to installation of windows 7.

  gengiscant 09:07 22 Mar 2010

Any help here, click here

  fishmad pete 09:36 22 Mar 2010

Link is to a similar discussion group to where I found that this could be an issue between amd and win7. However the last comment seems to put the ball in the court of win7. Although nearly every post stating they have same problem is on an AMD chipset board.
I am using the 64 bit version of windows7 those using 32bit don't seem to have a problem

  john bunyan 09:52 22 Mar 2010

I have w7 Ultimate 64 bit and AMD 2 core (2 x 2200) with MSI K8N SLI-F Motherboard. Seems to read and write ok to floppies, but thanks for raising the issue as I had not checked that point before as I rarely use them now but fave a lot of historical stuff on them.

  fishmad pete 15:11 03 Apr 2010

Found out that by disabling HPET in bios windows7 formats and writes to disks successfully

hope this helps someone else sometime

  DJ.Ryan 16:46 03 Apr 2010

why are you still using floppy disks,u do know that there are things called usb which have a little bit more space,1gb,2gb,4gb,8gb,16gb,32gb,64gb,128gb and if thats not enough external hdd which can be as much as 2tb(2000 gb) just thought id let you know

  john bunyan 18:50 03 Apr 2010

I do not, these days, use floppies much. However I have many older floppies wit graphs, data etc in Lotus format that I want to access from time to time and it would take too long to transfer them to other media. When HD's were only abot 2.5 Gig floppies could hold over 200 typical letters etc. Your reply , I think, is a bit patronising.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?