Unable to remove a program from add&remove.

  Meshuga 09:57 04 Mar 2007

OS is xphome sp1. I am trying to remove Google Earth using add and remove but get a message saying that it has encountered an error and is unable to remove it. I have tried doing it in Safe Mode but get the same message. Any suggestions please?

  skidzy 10:00 04 Mar 2007

Remove while in safemode or click here

  skidzy 10:00 04 Mar 2007

Sorry just read again about you have tried safemode..oops !

  skidzy 10:01 04 Mar 2007

is there a reason why you still use sp1 ? updateing to sp2 would be a good start if possible.

  birdface 10:29 04 Mar 2007

Try removing it from C Cleaner.

  Jackcoms 10:32 04 Mar 2007

Google Earth has its own un-installer.

Use that

  PA28 10:50 04 Mar 2007

Try the age old remedy for any software that might have been damaged along the way - reinstall it completely and then uninstall.

  Daiol 11:21 04 Mar 2007

try this it worked for me and many others have a go.click here. i hope that was the correct link!

  Meshuga 11:44 04 Mar 2007

skidzy, sorry about the delay in coming back, also sorry for my error, I do have SP2, typo error.
Thanks buteman, will try that.

Jackoms, looked for its own uninstaller but could not find it.

PA28, will try that.

Daiol, your link goes nowhere. "Not found on Server. Thanks to all who replied.

  Jackcoms 11:50 04 Mar 2007

"looked for its own uninstaller but could not find it".

Start; All Programs; Google Earth; Uninstall or Repair

  Meshuga 12:25 04 Mar 2007

Tried PA28s method of downloading and then removing. That did the trick. Thanks PA28 and everyone for suggestions.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?