Unable to install McAfee

  Jonah(without the whale) 09:59 29 Mar 2010

To cut a long story short - I was advised by McAfee to uninstall and re-install 3-user Total Protection from my McAfee Account (which I have done before and all was OK), but this time having thoroughly cleaned my PC of Mcafee first, the latested re-install fails.
The software is first downloaded, and then a second phase starts where the software is installed and it alays fails at the Anti-Spam stage. But no details are given. McAfee virtual tecnician just says there the software cannot be installed.
CHKDSK says that there is a file problem, and although I ran CHKDSK with the C:/F setting, is still has not sorted out the file problem.
I'm using XP home edition.
I must have tried downloading/installed about 20 times - and spent about 2 hrs with McAfee on-line, but it appears this file problem is stopping the installation.
I have a suspicion that a few days ago my machine was running something (can't recall what) and looked as if it had hung, so I reset the machine, and maybe caused the problem. Any ideas please?

  birdface 10:09 29 Mar 2010

Maybe a system restore to before you made the changes.
Then use Revo Uninstaller to remove it.

  cocteau48 10:16 29 Mar 2010

You say you have "thoroughly cleaned my PC of Mcafee first".

Did you try the dedicated Mcafee removal tool:click here

  Jonah(without the whale) 10:37 29 Mar 2010

Thanks for your responses but it's bad news folks.
System restore msyteriously disappeared from my machine ages ago, and I have yet to get round to reinstaling it (found the instructions a bit daunting to tell the truth)
And, I have the McAfee removal tool on my machine and have used it many times while trying to sort this out.
I am inclined to think that it's not actually McAfee programs that are the problem, only that my machine is not in a rasonable state to accept the McAfee programes. My theory is that it's this file problem in my hard disk - I have thought a bit more and one CHKDSK message a day or so ago was to the effect that something like some unussed files are allocated. The last time I ran CHKDSK did not report this, only a file problem, and, the CHKDSK screen closed itself very quickly too, rather than waiting for me to close it.

  birdface 10:50 29 Mar 2010

I suppose you have run Malwarebytes free version to see if there are any problems.
Sometimes it is Malware that stops security programs from installing or running.
So maybe give it a try if you have not already done so.

  Jonah(without the whale) 11:50 29 Mar 2010

Hi Buteman - Thnaks for your response. I haven't heard of Malwarebytes. If you think it's worth a go, I'll do that - do you have a link where I can get it please?

  Jonah(without the whale) 06:36 30 Mar 2010

I've tried running Malwarebytes and while it found a host of registry problem, I could not fix them with M-bytes because on doing the scan it then demanded money before any fix. I use System Mechanic to keep my machine clean and that did the job for me. I've also run this suite of progammany times ands till cannot get McAfee to install. Help!

  birdface 07:49 30 Mar 2010

Are you sure you downloaded the free version.

click here

Never known it to find registry faults before.

  fishmad pete 08:49 30 Mar 2010

This problem could be down to a bad installation of another program. Try this tool from Microsoft. when runing it don't remove programs that you know are still installed. click here

It sounds to me that you may have some malware onboard. If pressing CTRl+alt+del or typing "regedit" in RUN brings up that you require administator rights to run them then more than likely you have been infected. (your PC manufacturer may have disabled them like they did on my sons PC, spent ages looking for a virus!).

Hope the above works

  fishmad pete 08:51 30 Mar 2010

Further to my last. You say you ran Ceck Disk, have you run System File Checker (SFC /runnow). This will check you system files and will replace any incorrect ones

  Jonah(without the whale) 08:53 30 Mar 2010

Hi Buteman. Thanks for your response. I loaded what I thought was the free version, but not from the lnk you have kindly provided (which I've just checked). I'm not at my own computer right now so will not be able to download the free version until this evening - I'll give that a go then.
Just for the sake of interest, the version I used, provided a checklist of all kinds of thing for the product to check - DLLs, the registry and between 15-20 other things.
Many thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?