Unable to get rid of PCeU Ransomware Virus

  Chris2k6 20:04 21 Oct 2014

Hi, I'm new to the forums but I've got a hugely annoying virus,

I've recently become victim to the PCeU ransomware virus. As soon as it popped up I looked online for a solution. The first solution I came across was to start my laptop up in safemode, however on starting up my laptop, pressing f8 would do nothing. People also suggested starting it up and pressing shift with f8 but nothing happened. So then I tried another solution which involved using HitmanPro Kickstart on a USB drive and starting the infected laptop with the usb plugged in. I read that on startup I should be prompted to press a key such as f10, f11 or f12. However it just loaded up to login screen straight away! I looked it up and for my laptop it's f12. I tried pressing this and it brings up the boot menu. However I can see the flash drive option on it, only "windows boot manager", "efi network 0 for ipv4" and "efi network 0 for ipv6" So I went to move on to another solution until i realised it required a cd/dvd, which my laptop doesn't have....

So I'm kind of stuck and need a solution. My laptop is a Lenovo Y510P and is operating windows 8.1 Thanks for taking the time to read this and hopefully someone can help me. Cheers

  Fruit Bat /\0/\ 20:47 21 Oct 2014

F1 to enter BIOS

Select security tab

Secure Boot - set to disabled

Click on "Reset to Setup mode"

Go to Startup and select UEFI/Legacy and set to Both

Press F10 to save and exit

As it reboots press F12 to select Boot devices

You should now see your USB drive - select it.

It should now boot from your USB drive if you have mabe it bootable with Hitmanpro kickstart.

  Chris2k6 21:29 21 Oct 2014

Thanks for the quick reply. I'm guessing I should be pressing f1 on start up? I press it as soon as I switch my laptop on and nothing happens, just straight to login screen...

  Fruit Bat /\0/\ 21:42 21 Oct 2014

To get into Bios press F2 as you switch on


Press the Novo button and select BIOS setup from the menu.

  Chris2k6 21:55 21 Oct 2014

Thank you again for quick reply. F2 works :-)

However i get to this point and I get a bit lost......

"Click on "Reset to Setup mode"

Go to Startup and select UEFI/Legacy and set to Both"

I click on "reset to setup mode" and i get an option for "yes" or "no"

Then I can't find "startup"

  Chris2k6 22:03 21 Oct 2014

There's a "boot" tab. I go on that and it gives me a boot mode option, which gives me the options for UEFI or Legacy Support, but not both. If i choose Legacy then I get another option for boot priority....

  RobCharles1981 23:58 21 Oct 2014

This Youtube Video will certainly help you.......

click here

  Chris2k6 07:41 22 Oct 2014

I watched that video earlier, but I don't think it is anygood as it mentions running a CD, which I don't have the option to do so with having no cd/dvd drive on my laptop

  Fruit Bat /\0/\ 18:31 22 Oct 2014

set to leacacy and then what options do you get for boot priority? set USB as first boot device and HDD as second boot device.

  Chris2k6 18:39 22 Oct 2014

I set boot mode to legacy support. I then get boot priority options for UEFI First or Legacy First.

Underneath "boot mode" and "boot priority" there's a "USB Boot" option which is set to enabled

  Fruit Bat /\0/\ 19:28 22 Oct 2014

Set legacy first

then select usb boot.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review

Procreate's iPhone app offers new brushes, a larger canvas and better support for the iPhone 8/X

Best multi-room speakers for iPhone & Mac owners

Streaming : comment regarder le lancement de Xiaomi en France ?