Unable to associate a file type

  Ptolemy 20:23 26 Sep 2006

When I right click on an mp3 I used to have Audacity listed in the "Open with..." options.

A while ago a uninstalled/reinstalled Audacity and since then it has vanished from the options and although I browse and select it Audacity is never added to the list.

I've also tried to to set all mp3s to open with Audacity, both via the files properties and via the File Types association. On all occasions I browse to Audacity.exe and select it but my PC behaves as if I haven't done anting and the normal list of applications remains unchanged.

I can open mp3s from inside Audacity once it's open without any problem, but I can't add it to the default list.

I've tried removing Audacity and all files relating to it and reinstalling without sauces.

Can anyone explain what's going on and how I can rectify it.

  STREETWORK 20:49 26 Sep 2006
  Ptolemy 21:49 26 Sep 2006

Streetwork - thanks - the link didn't contain the exact solution, but managed to figure one out from the info supplied.

For anyone's reference;


scroll down to "Applications" and find the application in question.
There will be a sub-key called "shell" that should have two sub-keys of its own: "open" and "play" and both of these should have sub-keys called "command" - if these are missing create them, then modify the data in the "command" key to direct it to the the application with the address in " and suffixed by %1" - so Audacity is shown as "C:\Program Files\Audacity\audacity.exe" "%1" - that's it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?