Hot Topics

Trying to upgrade HDD to M2 Bootable Drive

  Macintyre91 00:43 27 Jan 2020

Hi all,

I'm a first time poster and before I start, I just want to say that whilst I am technically adept, what I'm trying to do has turned out to be slightly more tricky than I first anticipated.

Computer details:

Make and model: Lenovo Ideacentre 720 (90H1000BUK)

Original Drive (C Drive): ST2000DM001 Hard Drive - 2 TB.

New Drive (F Drive): ADATA SX8200PNP M2 SSD Drive - 1 TB

OS: Windows 10 Home

This PC is store bought with no other upgrades.

I recently began playing Cities: Skylines and noticed that creating and loading games took an eternity. I noticed that whilst the RAM levels were very low (good), the disk utilisation was almost always at 95-100%. Confident that an SSD would improve, if not solve the problem, I went online.

The new drive (ADATA) fits into a slot on the motherboard, but there is no capacity in the case to screw the M2 into place (meaning it stands at a 30* angle). Regardless, Windows 10 identifies this as a drive and I am able to freely move files to the drive.

I transferred the desktop location to the new M2 drive and this worked perfectly. I restored the PC to a point before I done this action, and cloned the entirety of my C: drive onto the new M2 drive (partitioning the drive in order to fit everything on - screenshot attached). This is unfortunately where I have hit a snag.

Although the Windows explorer shows the new M2 drive with all of the C Drive files, I have attempted to run Lenovo Bios, which again identifies the M2 as a drive, showign the correct name, however this does not appear as a bootable drive in the startup menu.

1) I've tried restarting the PC (with and without the M2 Drive). 2) I have tried removing the HDD, but without this drive Windows has a critical error as there is no alternative boot drive set up. 3) I have formatted the partitions to match those of the original HDD.

Basically, the drive continues to be usable as a storage drive, but I need to understand how I can make this bootable drive to run windows. I do not want to do a clean installation of Windows 10 if there is an alternative.

If there is any further information I can provide please let me know.

  x13 09:10 27 Jan 2020

Your image seems to show that your cloning is messed up -

Hopefully you can still boot from the hard drive (with the M2 disconnected) and create an image with Macrium (as backup) on to another USB drive, very important to do that, and create a recovery bootable Macrium media. If things go wrong you can revert to a working image. Might work just connecting the M2 with the hard drive disconnected, booting from the rescue media and re-instating the image on to the M2. Looks like the Lenovo has its own recovery partition?

Found this info that should also be useful - forums.lenovo

  Macintyre91 14:37 27 Jan 2020

I'll have another go tonight at cloning and update the forum. The computer does still boot from the Hard Drive and works as normal.

I apologise as I'm on my phone and when scrolling I marked 'not as answer'. I'll sort this when I'm home too. Appreciate your help.

  Flat Earther 01:48 28 Jan 2020

What program did you use to clone the disk? Both ADATA and Seagate offer free versions of Acronis which will clone the entire disk and resize the C drive automatically.

  Macintyre91 08:30 28 Jan 2020

Hi Flat Earther,

I used Macrium Reflect. I attempted it again last night making sure to copy everything in the order it was on the original drive but didnt have much time for anything else after work. Still working on it.

  Flat Earther 12:01 28 Jan 2020

I've not used Macrium but I see at the bottom of your screenshot is the option 'Clone this Disk...'

As you are messing around with individual partitions and their order suggests you're doing something different. You should just need to clone disk1 to disk2 and hopefully it will apply the reduction in size to the C drive, as Acronis would.

  Macintyre91 12:21 28 Jan 2020

Hi Flat Earther,

Macrium doesnt appear to automatically reduces partition sizes. When a partition is added you can only update the most recently added, the original partitions cannot be edited. As a result I made the system partitions to the minimum space allowed and left the storage space to last to allow maximum storage space on the smaller drive, however in turn this reordered the partitions as a result. I didn't think this would create problems as this is the first time doing this, but thinking about it I can understand why it would.

I've wiped the drive and re-cloned exactly as appears on the original drive. I'm going to have another go tonight.

Cheers

  x13 12:56 28 Jan 2020
  Flat Earther 13:01 28 Jan 2020

Having looked into Macrium I can see it has to be done manually, so on adding the C drive you'd need to enter the partition properties and adjust free space after to 22GB for the last 3 partitions.

If you still having problems i'd suggest trying the ADATA version of Acronis.

  x13 13:16 28 Jan 2020

Flat Earther yes it has to be done manually. What I do is drag all partitions down to the destination drive except the C partition and make a note of the space left. Cancel the instruction and start again. Drag the partitions down from the left and when you get to the C partition change the size to what you noted previously. Drag the C drive and any other partitions left to do. That's it.

  Macintyre91 18:47 28 Jan 2020

Hi x13 and Flat Earther

So it looks like the slight modifications I used when cloning the hard-drive did create the issue. When I ran Macrium and cloned the disk again last night, I left all system partitions as they were, but amended the size of the C: drive as you suggested. I also created the partitions in the same order as they were on the original drive.

When I did this and ran Lenovo bios, the system identified the M2 as bootable and allowed me to assign this as the primary boot drive.

Really appreciate the time you guys took to help, pretty sure if I had any hair I'd have ripped it out!

Thank you very much, Macintyre91

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

5 video games we want to see as movies

How to draw an eye

The best games on Apple Arcade

Les meilleurs écouteurs et casques audio pas chers (2020)