Trying to fit 2nd H/D in old Compaq

  Podsville 19:17 03 May 2003

I was given an old Compaq Presario 4118, running Win 95, with a 1.2 gig H/D. Just to give it a tad more storage I am trying to add a 2nd 1.6 gig H/D. I have tried it as master on secondary also slave to the Cd rom on same. Just about all the combinations I can think of. I am sure of jumper settings because they are printed on the underside of the drive (Western Digital Caviar 21600) On boot up the drive is found on the Compaq utility and looks OK (its also therein the device manager) but wont show in Windows or even from the DOS prompt! Am I correct in thinking the bios on this old Compaq is actually on the hard drive and could that be the problem? Anyone any idea's I might try? This is not dire as the Compaq will be only a second PC for me to do some work on while my son hogs the Mesh.

  woodchip 19:24 03 May 2003

It depends what you call old, as old IDE needed a Driver, check if you still have some disc look for IDE for motherboard

  LastChip 19:27 03 May 2003

This has the symptoms of either not being formatted or, being formatted in a form that DOS/Windows doesn't recognize.

Can you expand a little on the history of the drive please?

It's strange that you can "see" the drive on boot-up and in Device Manager, and I would have thought that if you had a BIOS problem, it would not be recognized at all.

However, Compaq are notorious for locking down what you can (or cannot) do with their machines, so I stand to be corrected.

  woodchip 19:27 03 May 2003

PS can you remember if the IDE ribbon cable connected direct to the motherboard or to a riser card. If a riser then you will need a driver for the card

  Podsville 20:34 03 May 2003

Woodchip / Lastchip, Many thanks for response. If I can expand some. The drive was also a gift from a friend. He said it has some files and Win 98 on it. I would be going to format it if I could get it recognised. The IDE cable (I have tried several) is connected direct to the secondary channel on the motherboard. The only items on the riser card are the modem and NIC.
I had the best result when I tried the drive on its own on the secondary channel and jumpered as CS ( cable select) It showed up better in the Compaq utility that way but still not in Windows. Its just puzzling me this one!

  woodchip 22:12 03 May 2003

Start with Floppy disc and change drive letters, and do a dir to see if it will allow you to see the files on the disc. if it does you can format the drive in dos

  LastChip 23:09 03 May 2003

You could take a look in he BIOS, and see if it's set to auto recognize the hard drive.

If (by any chance) the BIOS is set manually to a predetermined setting, that could be where the conflict is.

Certainly, the drive size should not be a problem, keeping in mind, it already recognizes 1.2 GBt's.

  T0SH 09:40 04 May 2003

Most old Compaq machines use the cable select setting on drives, the position on the ribbon cable determines the master/slave setting

  Podsville 13:56 04 May 2003

Tosh, many thanks for response in fact thanks to all. I did in fact get a better result when I fitted the drive on its own cable and jumpered for CS. However it still wouldnt show in Windows or from DOS prompt. I think I will now just put this one on the back burner for a while. Its just taking up too much time.
Once again many thanks to all.
Woodchip, many thanks again I tried changing the drive letters manually, the cursor would go into the box in the drive properties but I could not type anything in there. I also tried adding the line lastdrive=g or whatever to the config.sys file but that made no difference. The bios (of sorts) is a strange old thing on the Compaq.

  DieSse 14:16 04 May 2003

If it's not partitioned/formatted correctly, it won't show at the DOS propmt. What you need to do is to run fdisk first. This will allow you to remove and old partitioning information on the drive, and re-set it up with a new partition. Then you can format it, then it should appear in DOS and Windows.

To avoid calamitous errors, i suggest you try this with only this one drive connected (ie disconnect your main drive) - then whatever you do, you can't make a slip and wipe out your existing setup.

  BlueMeanie 18:55 05 May 2003


Older Compaq PC's have not got the secondary IDE channel activated by default!!

Down load the Compaq set up disks, if you are unable to access the BIOS (try F10 when a black flashing cursor appears at the top right of the screen) and activate the secondary IDE channel.

As already stated above often Compaq uses the Cable Select (CS) option, use the original cable that was in the PC if possible.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Inside the iMac Pro - Apple's most powerful Mac yet

iMac Pro release date, UK price & specs

Comment nettoyer Windows et optimiser son PC gratuitement ?