Trust Bluetooth Mouse MI-5700Rp

  Flankforward 09:39 06 Aug 2008

I bought one of these for my High Grade notebook, but it is not recognised on 'add device' for Bluetooth. The notebook has Bluetooth Radio, and Enumerator and Dongle drivers which Windows tells me are up to date and the devices are working properly. I've checked wireless LAN is turned on.

I think I have followed all the instructions including switching on the mouse and pressing the small button on the bottom. I've set blootooth options to allow connection.

Am I missing something, or must I send it back?

  mooly 12:06 06 Aug 2008

What operating system are you running ? I too have Trust bluetooth mouse and cheap Dongle from Argos. To cut a long story short I had endless problems -- everytime an issue or lockup occurred it seemed the bluetooth was at the bottom of it. I was initially using the BlueSoliel software supplied but gave up on this. 16 Months ago changed from X.P. to Vista via the free offer that came with notebook. I was pleased to find Vista's own drivers worked perfectly -- well untill 12 months ago. There was a windows update that stopped all functionality of the bluetooth. I could restore back and bluetooth worked !! So I "hid" that particular update and carried on but subsequent updates must have incorporated whatever the problem was and that was that. I ditched it and use a normal wireless mouse (Still Trust) that's been great. Never resolved the bluetooth issue, asked on this forum and never received any replies. Like you the mouse is discoverable but nothing is ever found.

  Flankforward 16:04 06 Aug 2008

OS is Vista. I haven't used a dongle- thought I didn't have to with a Bluetooth- enabled machine. Might I be wrong?

  mooly 11:41 07 Aug 2008

Possibly, that is mentioned a lot with ACER notebooks. My ACER has the option to add Bluetooth internally but is supplied as standard without, even though the Bluetooth "switch" and LED are fitted. I never cracked mine, control panel reports all working normally. Interestingly when I last had another go a few months back although it never recognised the mouse, it did discover another Bluetooth device ( probably a neighbour with something ) so the dongle is receiving OK. Sorry I can't be more help, it was the update that seemed to cripple mine, I could prove it by keep restoring back and it then worked.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?