Trouble with the two CD/Dvd drives

  StanB 12:23 19 Sep 2013

Have two CD/DVD drives on Dell Inspiron 530 –Win XP .

Inserting new CDs/DVDs gives messages – E:\ is not accessible – Incorrect function Other drive says – Please insert disk into Drive D:

I can and use pre-recorded disks on both drives- no trouble.

What have I done to cause this? Thanks for any help. Stan

  Press Man 13:15 19 Sep 2013

When you say "new cds/dvds" are they blank, no information/data on them? Are both the drives cd/dvd players, and not writers?

  StanB 14:28 19 Sep 2013

One is a REWRITER and one is a READER, I get an error message from both drives when trying brand new empty disks saying 'Please insert a disk'. (I have tried various disks eg CD-RW, CD-R, DVD-R and DVD-RW with the same result.

When I try pre-recorded disks they specify the contents and seem no problem.

many thanks for your reply, Stan

  Press Man 14:32 19 Sep 2013

Go in to Device Manager and find the 2 CD/DVD drives and uninstall them. Then reboot the machine and let Windows find the drives and install the required drivers.

  Fruit Bat /\0/\ 16:46 19 Sep 2013

Start / run / services.msc

check imapi cd burning service enabled

  Fruit Bat /\0/\ 16:47 19 Sep 2013

if that doesn't work try

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41 Try this if the optical drives are not appearing in My Computer or Device Manager. (This is sometimes caused by the removal of Roxio or other writing software.)

click here and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect. This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7. You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes click here works for W7 Vista or XP click here


  bumpkin 16:54 19 Sep 2013

StanB, this is green ticked. Is it resolved? if not uncheck it or you may not get many replies.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?