TP Link Homeplugs, now socket sensitive?

  Epirb406 22:28 13 Jan 2015

Hi All,

I have been running a network for around six months which includes a TP Link Homeplug adapter as a wireless access point for three IP CCTV cameras in my workshop which is some 25 distant from the house.

As the summer has turned into winter I have seem frame rates from these cameras drop, I thought nothing of it really, assuming that something had changed but without too much idea what and unconcerned because it was still working well enough to catch the badgers digging up my lawn!

However, last week the connection dropped out entirely.

I spent a pretty frustrating weekend looking at network and hardware issues, including isolating any other equipment in the workshop, drill chargers, heaters etc, all to no avail.

Finally this evening, on a hunch I tried the adapter in a different socket. It works fine.

So, same workshop, same 240 ring, all sockets live and functioning, three sockets can make a connection, three can't.

Why not, and why could it previously?

Any experience out there that could help?

All the best and thanks in advance,


  wee eddie 13:22 14 Jan 2015

As your workshop may be less warm and dry than the house, I suspect that oxidation of the contacts may be your problem.

If this is the problem, a possible solution is to get a standard 3 pin plug and insert it into the socket several times. Also, using a pencil, run it over the pins of your Homeplug Adaptor

  Epirb406 20:38 14 Jan 2015

That's a fair shout Eddie, I'll give it a look, it is maddeningly intermittent as I tried one of the dead sockets earlier today and it connected, lasted about 15 mins and then dropped the connection.

A bit of verdigris might just be it, I'll let you know.



  Fruit Bat /\0/\ 21:09 14 Jan 2015

Are they getting affected by a temperature drop?

  Epirb406 20:25 29 Mar 2015

Hi all,

Been aware that I hadn't been back and tidied this up but was rather hoping to be more definitive than I can be right now!

I tried cleaning the contacts, glued sandpaper to the plug prongs in fact! Nothing changed.

I therefore stuck with the socket it was in and it has worked all winter, not as well as when first installed, between 1 and 1.5 Fps on the ip cams but it continued to work whereas the rest of the sockets didn't

This weekend I replaced the mains supply cable to the workshop, going from 2.5mm to 4mm wire, just because I could, no real need. The Fps on the cams leaped to 2 to 2.5. Interested I tried the 'dud' sockets which connected and worked well.

so, conclusion? Not so sure but it seems that it is a conductivity/ resistance issue, the two sockets are just operating on the fringes of what is possible.

Hope that may help those that come next and thanks for your help and thoughts gents.

All the best,!


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?