Touchpad stopped responding

  Granger 13:08 21 Feb 2005

My laptop's touchpad has stopped working completely. Acer 803LCi XP Pro SP2 fully up to date. Virus software also up to date and finds nothing.

It first happened when I restarted in safe mode for a defrag, so I guess it's not a conflict? But now it doesn't work in any mode. I'd recently done some Windows updates, including a new smartcard reader driver, but a System Restore didn't help. I disabled the smartcard services from running just in case. Device Manager says the device is working properly. Event Viewer shows nothing relevant.

Maybe its just broken but I don't believe that - it stopped working on a reboot, and anyway the laptop hadn't been moved for ages, there was no shock or anything.

What do you reckon?

  FelixTCat 13:34 21 Feb 2005

Try deleting the touchpad from Device Manager and rebooting. Win should find the "new" device and load the drivers. If a driver became corrupt, this should fix it.

If that doesn't work first time, repeat it but tell Win to load new drivers. Point it at the driver supplied with your laptop (usually on a disk or partition of the laptop).

  geeza 13:48 21 Feb 2005

Cdheck your BIOS settings and see if it is enabled, I know that you can do this on Dell laptops

  Granger 14:20 22 Feb 2005

Hi, thanks for the responses. I checked the bios and it's enabled. I used device manager to uninstall the device, and the drivers reinstalled on reboot. Still no good. Felix - you said try telling Windows to load new drivers. How do I do this? It didn't give me a choice, just went ahead and installed the one it had already.

  FelixTCat 17:13 22 Feb 2005

Try deleting the touch pad in Device Manager and then do a manual Add New Hardware without rebooting - that should give you the option to load new drivers.

  Granger 17:47 24 Feb 2005

Right, I uninstalled from Device Manager. I also then uninstalled from Add/Remove programs. I couldn't see what you meant about a manual Add New Hardware. There's Add Hardware in Control Panel and I tried that, but it just seemed to tell me everything was OK. This after I uninstalled the drivers, so it just listed a PS/2 mouse.

So I used Device Manager, found the PS/2 mouse, and updated the driver, directing it to the driver on the original CD. Restarted, still not working.

So - windows still detects a pointing device there. But it won't work with or without drivers. Any otehr ideas, please?

  FelixTCat 19:01 24 Feb 2005


After you have done the deletions, DO NOT REBOOT. Use the Add Hardware wizard, tell it you have already connected the hardware. The touchpad shouldn't be in the list.

Scroll to the bottom of the list to Add a new hardware device and click Next

Click the Install the hardware that I manually select from a list button and click Next

Then Show All devices [Next] and Have Disk...

Then browse to the driver you want and install it.

See if the touchpad works now.n If not, reboot and see.

If still not, it may be broken. If so, get a cheap USB optical wheel mouse - I never use my touchpad anyway.

  Granger 11:32 26 Feb 2005

Hi again!

I got to the point where you select the manufacturer and device name but I don't know what they are. I looked in System Information but it doesn't say. What should I do?

  FelixTCat 13:38 26 Feb 2005

Just click on Have disk and browse to where the driver is (on the cd that came with the laptop?)

  Granger 09:27 28 Feb 2005

Without choosing the manufacturer and device name, I showed it where the drivers were, but it said it failed to find drivers for my device. Still without rebooting, I installed the driver using the interface provided on the supplier's CD. This normally works fine, but this time it said "A serious fatal error has occurred (#2 @10)". Seem to be running out of options!

  FelixTCat 09:33 28 Feb 2005

Yes, I fear we are. One option, of course, is a re-install of XP.

One other is to get a USB optical mouse. Small ones are available. I use one all the time as I find it much easier to use than the touchpad anyway.

A third is to live dangerously. Back up the registry, go into it and delete any references to the touchpad software. Reboot and see. This could, of course, lead to the first option above :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Creative studio Omnibus' brand identity for We Said Enough, a non-profit against sexual misconduct

What to ask Siri on the HomePod

Meilleurs VPN (2018)