Touchpad, Sound and USBs all stopped working..

  beare480 08:42 14 Mar 2015

Hi guys

As of yesterday afternoon my laptop was working fine. and then AVG told me it needed to restart for whatever reason, so I did. When the laptop booted up again, it came to a blue screen with alot of text, and hung there for a few seconds before telling me my computer had an error and that I should run an automatic repair. After about 15 minutes of the automatic repair, the laptop switched on again, and all seemed fine, however, the touch pad, including the left and right buttons of the touchpad, the sound, USB drives and the CD rom drives have all completely stopped working. I have no idea what may have caused this.

with my very limited knowledge of computers, I booted the laptop back up in safe mode, and the touchpad was working, but no sound or usb etc (i'm not sure if that is standard for safe mode anyway). I figured it may have been something to do with drivers, so I tried to update them but with no success, however I did 'roll back' the driver on the touchpad and that now seems to be working, although with very low sensitivity.

I've tried to restore the laptop back to an earlier date, but it just won't let me. In safe mode it says the System Protection is switched off, and when I try to switch it on following the windows help direction, it just won't let me. And when i've tried to do this out of safe mode, but again it won't work, a Lenovo message pops up saying 'Lenovo Instant Reset system software has been enabled. The windows System restore function is disabled'. I've also tried downloading the Lenovo system update, but when that searches for new updates, it crashes at 10%

I have a Lenovo G580 Laptop with Windows 7 home premium, I should also say that after a virus scan, nothing was found.

does anyone have any ideas on what has happened, or how to fix it?

Sorry for the long message, and thanks for your time. Scott

  Fruit Bat /\0/\ 14:57 14 Mar 2015

In normal mode uninstall the drivers for the usb and sound.

then reboot

windows should find and reinstall the drivers.

once usb is working then try the same with the touchpad. (if it doesn't work at least you can use a usb keyboard to try the touchpad drivers again.

  Secret-Squirrel 16:54 14 Mar 2015

"I've tried to restore the laptop back to an earlier date, but it just won't let me.."

Because you've got multiple problems I think that's a good idea. Thankfully there's another way to run System Restore that's much more reliable because it runs outside of Windows:

Turn your laptop off, turn it back on again and immediately start tapping the F8 key quickly and stop when you get to the "Advanced Boot Options" screen. Highlight "Repair your computer" with the arrow keys on the keyboard then hit the enter key to confirm your choice. Follow the on-screen prompts then click on System Restore when you get to the screen of recovery options.

Let me know how you get on please.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?