Touch pad stopped working on laptop

  steppenwolf070 13:21 18 Sep 2018

Greetings, my touch pad stopped working 3 days ago. For reasons I had to remove the battery and after I turned the laptop on, there was no cursor. I tried Fn+F5, but nothing happened. I reinstalled the driver couple of times, I made updates, I did a clean boot and other recommendations from the internet. I can't find any touch pad options. When I go to the additional mouse options it says "Unable to connect to the Synaptics Pointing Device Driver" and I should uninstall it, but I did it like 20x. Seems like the laptop doesn't recognize the touch pad. I don't think that there's a physical damage.

Could anybody help? thank you for your time.

  difarn 18:22 18 Sep 2018

I don't know what make your laptop is. Did you also try Fn + F11 and Fn + F7?

  steppenwolf070 18:56 18 Sep 2018

I tried every combination possible. its the driver I think

  difarn 19:26 18 Sep 2018

Came across this in an article:- Start button type msconfig from search On the startup tab open taskmanager right click the synaptics touchpad and under compatibility tab check run this program as administrator then restart Worth trying?

Have you tried rolling back the driver or your laptop to a previous date before the problem occurred?

Anyway thank you for the help sir.

  steppenwolf070 22:44 19 Sep 2018

tried anything, but still doesnt work

  difarn 13:48 20 Sep 2018

Does that include returning your PC to an earlier time before the problem happened? Which OS are you using and what make is the laptop?

Have you tried doing another hard reset, taking the battery out, removing the AC adaptor, pressing and holding the power-on button for 20 seconds, then using the fn + key to toggle the touchpad on/off?

When you reinstalled the drivers did you go to the manufacturer's website?

  steppenwolf070 21:44 24 Sep 2018

It bothers me that I cant go to the touchpad settings cuz it says thats unable to connect to the synaptics touchpad driver

  difarn 20:43 25 Sep 2018

Have you tried all of the other suggestions? YOu have not said which OS you are using.

Have you tried this?

Go to Start -> Control Panel -> System -> Hardware tab -> Click "Device Manager" -> Find the item called Mice and pointing devices and click the + sign. If synaptics is listed right click and select Uninstall. After that completes go to the top of the Device Manager and select Action -> Scan for hardware changes...it should find the device and attempt to reinstall it and the driver.

  steppenwolf070 20:58 26 Sep 2018

i did, but it only shows my USB mouse.

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Google Home Hub review

Print legends Dan Mumford and Supermundane on making the leap from 2D to AR

How to watch Apple’s October 2018 iPad launch

OnePlus 6T : date de sortie, prix et autres rumeurs